Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Wireless daemon for Linux" |
| 2 | LICENSE = "LGPL-2.1" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09" |
| 4 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame^] | 5 | inherit autotools pkgconfig systemd python3native |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 6 | |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame^] | 7 | DEPENDS = "ell readline dbus python3-docutils-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git" |
Brad Bishop | 868407c | 2019-11-04 13:24:47 -0500 | [diff] [blame^] | 10 | SRCREV = "77f16ae26fc013477f6362a0c33f0e52e82863e0" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 14 | PACKAGECONFIG[wired] = "--enable-wired,--disable-wired" |
| 15 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono" |
| 16 | PACKAGECONFIG[systemd] = "--with-systemd-unitdir=${systemd_system_unitdir},--disable-systemd-service,systemd" |
| 17 | |
| 18 | EXTRA_OECONF += "--enable-external-ell" |
| 19 | |
| 20 | do_configure_prepend () { |
| 21 | mkdir -p ${S}/build-aux |
| 22 | } |
| 23 | |
| 24 | do_install_append() { |
| 25 | mkdir --parents ${D}${docdir}/${BPN} |
| 26 | install -m644 ${S}/doc/*.txt ${D}${docdir}/${BPN} |
| 27 | } |
| 28 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 29 | FILES_${PN} += "${datadir}/dbus-1 ${libdir}/modules-load.d" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | |
| 31 | SYSTEMD_SERVICE_${PN} = "iwd.service ${@bb.utils.contains('PACKAGECONFIG', 'wired', 'ead.service', '', d)}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 32 | |
| 33 | RRECOMMENDS_${PN} = "\ |
| 34 | kernel-module-pkcs7-message \ |
| 35 | kernel-module-pkcs8-key-parser \ |
| 36 | kernel-module-x509-key-parser \ |
| 37 | " |