Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require gstreamer1.0-plugins.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ & LGPLv2+" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ |
| 9 | file://get-caps-from-src-pad-when-query-caps.patch \ |
| 10 | file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
| 11 | file://make-gio_unix_2_0-dependency-configurable.patch \ |
| 12 | file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \ |
| 14 | file://0003-riff-add-missing-include-directories-when-calling-in.patch \ |
| 15 | file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 16 | file://0005-viv-fb-Make-sure-config.h-is-included.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | file://0009-glimagesink-Downrank-to-marginal.patch \ |
| 18 | file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | file://link-with-libvchostif.patch \ |
| 20 | " |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 21 | SRC_URI[md5sum] = "41dde92930710c75cdb49169c5cc6dfc" |
| 22 | SRC_URI[sha256sum] = "4093aa7b51e28fb24dfd603893fead8d1b7782f088b05ed0f22a21ef176fb5ae" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | |
| 24 | S = "${WORKDIR}/gst-plugins-base-${PV}" |
| 25 | |
| 26 | DEPENDS += "iso-codes util-linux" |
| 27 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 28 | inherit gettext gobject-introspection |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
| 30 | PACKAGES_DYNAMIC =+ "^libgst.*" |
| 31 | |
| 32 | # opengl packageconfig factored out to make it easy for distros |
| 33 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL |
| 34 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" |
| 35 | |
| 36 | PACKAGECONFIG ??= " \ |
| 37 | ${GSTREAMER_ORC} \ |
| 38 | ${PACKAGECONFIG_GL} \ |
| 39 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ |
| 40 | gio-unix-2.0 jpeg ogg pango png theora vorbis zlib \ |
| 41 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ |
| 42 | " |
| 43 | |
| 44 | X11DEPENDS = "virtual/libx11 libsm libxrender libxv" |
| 45 | X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm" |
| 46 | X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm" |
| 47 | |
| 48 | PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" |
| 49 | PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia" |
| 50 | PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" |
| 51 | PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgbm libgudev libdrm" |
| 52 | PACKAGECONFIG[gio-unix-2.0] = "--enable-gio_unix_2_0,--disable-gio_unix_2_0,glib-2.0" |
| 53 | PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2" |
| 54 | PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor" |
| 55 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 56 | PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg" |
| 57 | PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu" |
| 58 | PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus" |
| 59 | PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango" |
| 60 | PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng" |
| 61 | PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora" |
| 62 | PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual" |
| 63 | PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis" |
| 64 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| 65 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm" |
| 66 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib" |
| 67 | |
| 68 | FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h" |
| 69 | FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" |
| 70 | |
| 71 | do_compile_prepend() { |
| 72 | export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/allocators/.libs" |
| 73 | } |