Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Portable Hardware Locality (hwloc) software package" |
| 2 | DESCRIPTION = "The Portable Hardware Locality (hwloc) software package \ |
| 3 | provides a portable abstraction of the hierarchical topology of modern \ |
| 4 | architectures." |
| 5 | HOMEPAGE = "https://www.open-mpi.org/software/hwloc/" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=3282e20dc3cec311deda3c6d4b1f990b" |
| 9 | |
| 10 | SRC_URI = "https://www.open-mpi.org/software/${BPN}/v1.11/downloads/${BP}.tar.bz2" |
| 11 | SRC_URI[md5sum] = "0981a01935982aa7e850a96e0c3057b0" |
| 12 | SRC_URI[sha256sum] = "2be808383d8337846fe77ce49c7ad3336fb6857505494d85c0ac03f22c5bd1e7" |
| 13 | |
| 14 | UPSTREAM_CHECK_URI = "https://www.open-mpi.org/software/hwloc/v1.11/" |
| 15 | |
| 16 | inherit autotools pkgconfig |
| 17 | |
| 18 | DEPENDS += "ncurses udev zlib" |
| 19 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}" |
| 20 | |
| 21 | PACKAGECONFIG ?= "pci libxml2 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" |
| 22 | |
| 23 | PACKAGECONFIG[numactl] = "--enable-libnuma,--disable-libnuma,numactl,numactl" |
| 24 | PACKAGECONFIG[libxml2] = "--enable-libxml2,--disable-libxml2,libxml2,libxml2" |
| 25 | PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo" |
| 26 | PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess" |
| 27 | |
| 28 | # Split hwloc library into separate subpackage |
| 29 | PACKAGES_prepend = " libhwloc " |
| 30 | FILES_libhwloc += "${libdir}/libhwloc.so.*" |
| 31 | RDEPENDS_${PN} += "libhwloc (= ${EXTENDPKGV})" |