Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Opensource Implementation of WS-Management" |
| 2 | DESCRIPTION = "Openwsman is a project intended to provide an open-source \ |
| 3 | implementation of the Web Services Management specipication \ |
| 4 | (WS-Management) and to expose system management information on the \ |
| 5 | Linux operating system using the WS-Management protocol. WS-Management \ |
| 6 | is based on a suite of web services specifications and usage \ |
| 7 | requirements that exposes a set of operations focused on and covers \ |
| 8 | all system management aspects. \ |
| 9 | Openwsman Server and service libraries" |
| 10 | HOMEPAGE = "http://www.openwsman.org/" |
| 11 | SECTION = "Applications/System" |
| 12 | |
| 13 | DEPENDS = "curl libxml2 openssl libpam" |
| 14 | |
| 15 | inherit distro_features_check |
| 16 | REQUIRED_DISTRO_FEATURES = "pam" |
| 17 | |
| 18 | SRCREV = "e90e5c96e3006c372bf45e0185e33c9250e67df6" |
| 19 | PV = "2.6.5" |
| 20 | |
| 21 | SRC_URI = "git://github.com/Openwsman/openwsman.git \ |
| 22 | file://libssl-is-required-if-eventint-supported.patch \ |
| 23 | file://openwsmand.service \ |
| 24 | file://0001-lock.c-Define-PTHREAD_MUTEX_RECURSIVE_NP-if-undefine.patch \ |
| 25 | file://0001-Port-to-OpenSSL-1.1.0.patch \ |
| 26 | file://0002-Check-OpenSSL-version-number-to-allow-builds-with-ol.patch \ |
| 27 | " |
| 28 | |
| 29 | S = "${WORKDIR}/git" |
| 30 | |
| 31 | LICENSE = "BSD" |
| 32 | LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba" |
| 33 | |
| 34 | inherit systemd cmake pkgconfig pythonnative perlnative |
| 35 | |
| 36 | SYSTEMD_SERVICE_${PN} = "openwsmand.service" |
| 37 | SYSTEMD_AUTO_ENABLE = "disable" |
| 38 | |
| 39 | LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}" |
| 40 | |
| 41 | EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \ |
| 42 | -DBUILD_LIBCIM=NO \ |
| 43 | -DBUILD_PERL=YES \ |
| 44 | -DCMAKE_INSTALL_PREFIX=${prefix} \ |
| 45 | -DLIB=${baselib} \ |
| 46 | " |
| 47 | |
| 48 | do_configure_prepend() { |
| 49 | export STAGING_INCDIR=${STAGING_INCDIR} |
| 50 | export STAGING_LIBDIR=${STAGING_LIBDIR} |
| 51 | } |
| 52 | |
| 53 | do_install_append() { |
| 54 | install -d ${D}/${sysconfdir}/init.d |
| 55 | install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand |
| 56 | ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand |
| 57 | chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh |
| 58 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 59 | install -d ${D}/${systemd_unitdir}/system |
| 60 | install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system |
| 61 | |
| 62 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service |
| 63 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service |
| 64 | sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service |
| 65 | fi |
| 66 | } |
| 67 | |
| 68 | FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \ |
| 69 | ${libdir}/openwsman/authenticators/.debug/ \ |
| 70 | " |
| 71 | |
| 72 | INSANE_SKIP_${PN} = "dev-so" |
| 73 | RDEPENDS_${PN} = "ruby" |