Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require espeak.inc |
| 2 | |
| 3 | inherit native |
| 4 | |
| 5 | PACKAGES = "${PN}" |
| 6 | FILES_${PN} = "${layout_datadir}" |
| 7 | |
| 8 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 9 | TARGET_ARCH = "${MACHINE_ARCH}" |
| 10 | |
| 11 | do_compile() { |
| 12 | # Fixing byte order of phoneme data files |
| 13 | cd "${S}/platforms/big_endian" |
| 14 | sed -i '/^ *CC *=/d' Makefile |
| 15 | sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c |
| 16 | oe_runmake |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | ./espeak-phoneme-data "${S}/espeak-data" "." "${S}/espeak-data/phondata-manifest" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | cp -f phondata phonindex phontab "${S}/espeak-data" |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}${layout_datadir}/espeak-data |
| 23 | install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data |
| 24 | } |