Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "The GNU portability library" |
| 2 | DESCRIPTION = "A collection of software subroutines which are designed to \ |
| 3 | be usable on many operating systems. The goal of the project \ |
| 4 | is to make it easy for free software authors to make their \ |
| 5 | software run on many operating systems. Since source is designed \ |
| 6 | to be copied from gnulib, it is not a library per-se, as much \ |
| 7 | as a collection of portable idioms to be used in other projects." |
| 8 | |
| 9 | HOMEPAGE = "http://www.gnu.org/software/gnulib/" |
| 10 | SECTION = "devel" |
| 11 | LICENSE = "LGPLv2+" |
| 12 | |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5" |
| 14 | SRCREV = "b23000de1e47c7d580e0e220966dd1ee42a5e5bc" |
| 15 | |
| 16 | SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | file://CVE-2018-17942.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | do_install () { |
| 23 | cd ${S} |
| 24 | git checkout master |
| 25 | git clone ${S} ${D}/${datadir}/gnulib |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | cd ${D}/${datadir}/gnulib |
| 27 | git am ${WORKDIR}/CVE-2018-17942.patch |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 28 | } |
| 29 | |
| 30 | do_patch[noexec] = "1" |
| 31 | do_configure[noexec] = "1" |
| 32 | do_compile[noexec] = "1" |
| 33 | do_package[noexec] = "1" |
| 34 | do_packagedata[noexec] = "1" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | deltask package_write_ipk |
| 36 | deltask package_write_deb |
| 37 | deltask package_write_rpm |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | deltask do_deploy_archives |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 39 | |
| 40 | BBCLASSEXTEND = "native" |