Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for controlling team network device" |
| 2 | HOMEPAGE = "http://www.libteam.org/" |
| 3 | SECTION = "libs/network" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 7 | |
| 8 | DEPENDS = "libnl libdaemon jansson" |
| 9 | |
| 10 | SRC_URI = "git://github.com/jpirko/libteam \ |
| 11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ |
| 12 | file://0002-teamd-Re-adjust-include-header-order.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ |
| 14 | file://run-ptest \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | " |
| 16 | SRCREV = "91a928a56a501daac5ce8b3c16bd9943661f1d16" |
| 17 | |
| 18 | SRC_URI[md5sum] = "565114d70c41bff6093d8e57be284e8a" |
| 19 | SRC_URI[sha256sum] = "d65286379141db141bea33424ec0507bb0f827a0bf03d9c65004bb593e3d5545" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | inherit autotools pkgconfig ptest |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | |
| 25 | FILES_${PN} = "${libdir}/libteam${SOLIBS} \ |
| 26 | " |
| 27 | |
| 28 | PACKAGES += "${PN}-dctl ${PN}-utils" |
| 29 | FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \ |
| 30 | " |
| 31 | FILES_${PN}-utils = "${bindir}/bond2team \ |
| 32 | ${bindir}/teamd \ |
| 33 | ${bindir}/teamdctl \ |
| 34 | ${bindir}/teamnl \ |
| 35 | " |
| 36 | |
| 37 | RDEPENDS_${PN}-utils = "bash" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | RDEPENDS_${PN}-ptest = "python" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 39 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 40 | do_install_ptest() { |
| 41 | install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/ |
| 42 | } |