Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "XML-RPC for C/C++ is programming libraries and related tools to help you \ |
| 2 | write an XML-RPC server or client in C or C++." |
| 3 | |
| 4 | HOMEPAGE = "http://xmlrpc-c.sourceforge.net/" |
| 5 | LICENSE = "BSD & MIT" |
| 6 | LIC_FILES_CHKSUM = "file://doc/COPYING;md5=aefbf81ba0750f02176b6f86752ea951" |
| 7 | |
| 8 | SRC_URI = "git://github.com/mirror/xmlrpc-c.git \ |
| 9 | file://0001-test-cpp-server_abyss-Fix-build-with-clang-libc.patch \ |
| 10 | file://0002-fix-formatting-issues.patch \ |
| 11 | " |
| 12 | #Release 1.51.03 |
| 13 | SRCREV = "343a3b98e54999d67edb644bcd395aa9784fb16e" |
| 14 | |
| 15 | S = "${WORKDIR}/git/stable" |
| 16 | |
| 17 | DEPENDS = "libxml2" |
| 18 | RDEPENDS_${PN} = "perl" |
| 19 | |
| 20 | inherit autotools-brokensep binconfig pkgconfig |
| 21 | |
| 22 | TARGET_CFLAGS += "-Wno-narrowing" |
| 23 | |
| 24 | EXTRA_OEMAKE += "CC_FOR_BUILD='${BUILD_CC}' \ |
| 25 | LD_FOR_BUILD='${BUILD_LD}' \ |
| 26 | CFLAGS_FOR_BUILD='${BUILD_CFLAGS}' \ |
| 27 | LDFLAGS_FOR_BUILD='${BUILD_LDFLAGS}' \ |
| 28 | " |
| 29 | |
| 30 | EXTRA_OECONF += "--disable-libwww-client --disable-wininet-client" |
| 31 | |
| 32 | PACKAGECONFIG ??= "curl cplusplus" |
| 33 | |
| 34 | PACKAGECONFIG[abyss] = "--enable-abyss-server --enable-abyss-threads --enable-abyss-openssl,--disable-abyss-server --disable-abyss-threads --disable-abyss-openssl,openssl," |
| 35 | PACKAGECONFIG[cplusplus] = "--enable-cplusplus,--disable-cplusplus,," |
| 36 | PACKAGECONFIG[curl] = "--enable-curl-client,--disable-curl-client,curl,curl" |
| 37 | |
| 38 | do_configure() { |
| 39 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 40 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
| 41 | autoconf |
| 42 | oe_runconf |
| 43 | # license is incompatible with lib/util/getoptx.* |
| 44 | rm -fv ${S}/tools/turbocharger/mod_gzip.c |
| 45 | } |
| 46 | |
| 47 | BBCLASSEXTEND = "native" |
| 48 | |
| 49 | CLEANBROKEN = "1" |