Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Terminus fonts packages (console and X11)" |
| 2 | DESCRIPTION = "Terminus Font is a clean, fixed width bitmap font, designed for \ |
| 3 | long (8 and more hours per day) work with computers." |
| 4 | HOMEPAGE = "http://terminus-font.sourceforge.net/" |
| 5 | AUTHOR = "Dimitar Zhekov" |
| 6 | SECTION = "fonts" |
| 7 | |
| 8 | LICENSE = "OFL-1.1" |
| 9 | LIC_FILES_CHKSUM = "file://OFL.TXT;md5=9cadb26f4c5c005618c5ae74f041ec54" |
| 10 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | DEPENDS = "hostperl-runtime-native gzip-native bdftopcf-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz" |
| 14 | SRC_URI[md5sum] = "a8e792fe6e84c86ed2b6ed3e2a12ba66" |
| 15 | SRC_URI[sha256sum] = "f6f4876a4dabe6a37c270c20bb9e141e38fb50e0bba200e1b9d0470e5eed97b7" |
| 16 | |
| 17 | inherit allarch fontcache |
| 18 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | PACKAGECONFIG[x11] = "" |
| 21 | |
| 22 | # Don't use font cache mecanism for console packages |
| 23 | FONT_PACKAGES = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '${PN}-pcf', '', d)}" |
| 24 | |
| 25 | # Hand made configure script. Don't need oe_runconf |
| 26 | do_configure() { |
| 27 | chmod +x ${S}/configure |
| 28 | ${S}/configure --prefix=${prefix} \ |
| 29 | --psfdir=${datadir}/consolefonts \ |
| 30 | --acmdir=${datadir}/consoletrans \ |
| 31 | --x11dir=${datadir}/fonts/terminus |
| 32 | } |
| 33 | |
| 34 | do_compile() { |
| 35 | oe_runmake DESTDIR=${D} psf txt ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'pcf', '', d)} |
| 36 | } |
| 37 | |
| 38 | do_install() { |
| 39 | oe_runmake DESTDIR=${D} install-psf install-acm ${@bb.utils.contains('PACKAGECONFIG', 'x11', 'install-pcf', '', d)} |
| 40 | } |
| 41 | |
| 42 | PACKAGES += "${PN}-consolefonts ${PN}-consoletrans ${PN}-pcf" |
| 43 | FILES_${PN}-consolefonts = "${datadir}/consolefonts" |
| 44 | FILES_${PN}-consoletrans = "${datadir}/consoletrans" |
| 45 | FILES_${PN}-pcf = "${datadir}/fonts/terminus" |