blob: 6133b3a2708b14331dbcd820454c946bed95e954 [file] [log] [blame]
Brad Bishop63ae8782019-10-09 09:56:13 -04001SUMMARY = "NVMe management command line interface"
2AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
3HOMEPAGE = "https://github.com/linux-nvme/nvme-cli"
4SECTION = "console/utils"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
7DEPENDS = "util-linux util-linux-native"
8PV .= "+git${SRCPV}"
9
10SRC_URI = "git://github.com/linux-nvme/nvme-cli.git"
11SRCREV = "977e7d4cf59c3c7f89e9c093c91f991b07292e45"
12
13S = "${WORKDIR}/git"
14
15inherit bash-completion systemd
16
17do_install() {
Brad Bishop00ab2372019-10-14 11:06:18 -040018 oe_runmake install-spec DESTDIR=${D} PREFIX=${prefix} \
Brad Bishop63ae8782019-10-09 09:56:13 -040019 UDEVDIR=${nonarch_base_libdir}/udev SYSTEMDDIR=${systemd_unitdir}
20}
21
22pkg_postinst_ontarget_${PN}() {
23 ${sbindir}/nvme gen-hostnqn > ${sysconfdir}/nvme/hostnqn
24}
25
26PACKAGES =+ "${PN}-dracut ${PN}-zsh-completion"
27
Brad Bishop00ab2372019-10-14 11:06:18 -040028FILES_${PN} += "${systemd_system_unitdir}"
Brad Bishop63ae8782019-10-09 09:56:13 -040029FILES_${PN}-dracut = "${libdir}/dracut/dracut.conf.d"
30FILES_${PN}-zsh-completion = "${datadir}/zsh/site-functions"