Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer" |
| 2 | DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \ |
| 3 | library designed to provide low level access to audio, keyboard, mouse, \ |
| 4 | joystick, 3D hardware via OpenGL, and 2D video framebuffer." |
| 5 | HOMEPAGE = "http://www.libsdl.org" |
| 6 | BUGTRACKER = "http://bugzilla.libsdl.org/" |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "Zlib" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=2d4af6adb4d89aad0cdedbcc18c9a32f" |
| 12 | |
| 13 | # arm-neon adds MIT license |
| 14 | LICENSE_append = " ${@bb.utils.contains('PACKAGECONFIG', 'arm-neon', '& MIT', '', d)}" |
| 15 | LIC_FILES_CHKSUM_append = " ${@bb.utils.contains('PACKAGECONFIG', 'arm-neon', 'file://src/video/arm/pixman-arm-neon-asm.h;md5=9a9cc1e51abbf1da58f4d9528ec9d49b;beginline=1;endline=24', '', d)}" |
| 16 | |
| 17 | PROVIDES = "virtual/libsdl2" |
| 18 | |
| 19 | SRC_URI = "http://www.libsdl.org/release/SDL2-${PV}.tar.gz \ |
| 20 | file://more-gen-depends.patch \ |
| 21 | " |
| 22 | |
| 23 | S = "${WORKDIR}/SDL2-${PV}" |
| 24 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 25 | SRC_URI[sha256sum] = "d8215b571a581be1332d2106f8036fcb03d12a70bae01e20f424976d275432bc" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | |
| 27 | inherit autotools lib_package binconfig-disabled pkgconfig |
| 28 | |
| 29 | BINCONFIG = "${bindir}/sdl2-config" |
| 30 | |
| 31 | CVE_PRODUCT = "simple_directmedia_layer sdl" |
| 32 | |
| 33 | EXTRA_OECONF = "--disable-oss --disable-esd --disable-arts \ |
| 34 | --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ |
| 35 | --disable-video-dummy \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 36 | --disable-video-rpi \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | --enable-pthreads \ |
| 38 | --enable-sdl-dlopen \ |
| 39 | --disable-rpath \ |
| 40 | --disable-sndio \ |
| 41 | --disable-fcitx --disable-ibus \ |
| 42 | " |
| 43 | |
| 44 | # opengl packageconfig factored out to make it easy for distros |
| 45 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL |
| 46 | PACKAGECONFIG_GL ?= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}" |
| 47 | |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 48 | PACKAGECONFIG_class-native = "x11 ${PACKAGECONFIG_GL}" |
| 49 | PACKAGECONFIG_class-nativesdk = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} ${PACKAGECONFIG_GL}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | PACKAGECONFIG ??= " \ |
| 51 | ${PACKAGECONFIG_GL} \ |
| 52 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa directfb pulseaudio x11', d)} \ |
| 53 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland gles2', '', d)} \ |
| 54 | ${@bb.utils.contains("TUNE_FEATURES", "neon","arm-neon","",d)} \ |
| 55 | " |
| 56 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," |
| 57 | PACKAGECONFIG[arm-neon] = "--enable-arm-neon,--disable-arm-neon" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 58 | PACKAGECONFIG[directfb] = "--enable-video-directfb,--disable-video-directfb,directfb,directfb" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 59 | PACKAGECONFIG[gles2] = "--enable-video-opengles,--disable-video-opengles,virtual/libgles2" |
| 60 | PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" |
| 61 | PACKAGECONFIG[kmsdrm] = "--enable-video-kmsdrm,--disable-video-kmsdrm,libdrm virtual/libgbm" |
| 62 | PACKAGECONFIG[opengl] = "--enable-video-opengl,--disable-video-opengl,virtual/libgl" |
| 63 | PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 64 | PACKAGECONFIG[wayland] = "--enable-video-wayland,--disable-video-wayland,wayland-native wayland wayland-protocols libxkbcommon" |
| 65 | PACKAGECONFIG[x11] = "--enable-video-x11,--disable-video-x11,virtual/libx11 libxext libxrandr libxrender" |
| 66 | |
| 67 | EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 68 | CFLAGS_append_class-native = " -DNO_SHARED_MEMORY" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 69 | |
| 70 | do_configure_prepend() { |
| 71 | # Remove old libtool macros. |
| 72 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 73 | for i in ${MACROS}; do |
| 74 | rm -f ${S}/acinclude/$i |
| 75 | done |
| 76 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR |
| 77 | } |
| 78 | |
| 79 | FILES_${PN}-dev += "${libdir}/cmake" |
| 80 | |
| 81 | BBCLASSEXTEND = "native nativesdk" |