Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame^] | 1 | SUMMARY = "OpenGL Mathematics Library for C" |
| 2 | DESCRIPTION = "Highly optimized 2D|3D math library, also known as OpenGL Mathematics (glm) for `C`. \ |
| 3 | cglm provides lot of utils to help math operations to be fast and quick to write. It is community \ |
| 4 | friendly, feel free to bring any issues, bugs you faced." |
| 5 | HOMEPAGE = "https://github.com/recp/cglm" |
| 6 | BUGTRACKER = "https://github.com/recp/cglm/issues" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8dc95c4110ba741c43832734b51b7de7" |
| 10 | |
| 11 | SRC_URI = "git://github.com/recp/cglm;branch=master;protocol=https" |
| 12 | # Tag v0.8.5 |
| 13 | SRCREV = "7e5d1f435f628b873347eb052b7d6605b0b997f2" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | PACKAGECONFIG[build_tests] = "-Dbuild_tests=true,-Dbuild_tests=false," |
| 18 | |
| 19 | PACKAGECONFIG ?= "" |
| 20 | |
| 21 | inherit meson pkgconfig |
| 22 | |
| 23 | EXTRA_OEMESON += "--buildtype release" |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |