Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)" |
| 2 | DESCRIPTION = "A complete and free implementation of the OpenPGP standard \ |
| 3 | as defined by RFC4880 (also known as PGP). GnuPG allows you to encrypt \ |
| 4 | and sign your data and communications; it features a versatile key \ |
| 5 | management system, along with access modules for all kinds of public \ |
| 6 | key directories." |
| 7 | HOMEPAGE = "http://www.gnupg.org/" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | LICENSE = "GPL-3.0-only & LGPL-3.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \ |
| 10 | file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257" |
| 11 | |
| 12 | DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt" |
| 13 | |
| 14 | inherit autotools gettext texinfo pkgconfig |
| 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 17 | SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 18 | file://0002-use-pkgconfig-instead-of-npth-config.patch \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 19 | file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \ |
| 20 | file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \ |
| 21 | " |
| 22 | SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \ |
| 23 | file://relocate.patch" |
| 24 | SRC_URI:append:class-nativesdk = " file://relocate.patch" |
| 25 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 26 | SRC_URI[sha256sum] = "ee163a5fb9ec99ffc1b18e65faef8d086800c5713d15a672ab57d3799da83669" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 27 | |
| 28 | EXTRA_OECONF = "--disable-ldap \ |
| 29 | --disable-ccid-driver \ |
| 30 | --with-zlib=${STAGING_LIBDIR}/.. \ |
| 31 | --with-bzip2=${STAGING_LIBDIR}/.. \ |
| 32 | --with-readline=${STAGING_LIBDIR}/.. \ |
| 33 | --with-mailprog=${sbindir}/sendmail \ |
| 34 | --enable-gpg-is-gpg2 \ |
| 35 | " |
| 36 | |
| 37 | # A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg) |
| 38 | PACKAGES =+ "${PN}-gpg" |
| 39 | FILES:${PN}-gpg = " \ |
| 40 | ${bindir}/gpg \ |
| 41 | ${bindir}/gpg2 \ |
| 42 | ${bindir}/gpg-agent \ |
| 43 | " |
| 44 | |
| 45 | # Normal package (gnupg) should depend on minimal package (gnupg-gpg) |
| 46 | # to ensure all tools are included. This is done only in non-native |
| 47 | # builds. Native builds don't have sub-packages, so appending RDEPENDS |
| 48 | # in this case breaks recipe parsing. |
| 49 | RDEPENDS:${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}" |
| 50 | |
| 51 | RRECOMMENDS:${PN} = "pinentry" |
| 52 | |
| 53 | do_configure:prepend () { |
| 54 | # Else these could be used in prefernce to those in aclocal-copy |
| 55 | rm -f ${S}/m4/gpg-error.m4 |
| 56 | rm -f ${S}/m4/libassuan.m4 |
| 57 | rm -f ${S}/m4/ksba.m4 |
| 58 | rm -f ${S}/m4/libgcrypt.m4 |
| 59 | } |
| 60 | |
| 61 | do_install:append() { |
| 62 | ln -sf gpg2 ${D}${bindir}/gpg |
| 63 | ln -sf gpgv2 ${D}${bindir}/gpgv |
| 64 | } |
| 65 | |
| 66 | do_install:append:class-native() { |
| 67 | create_wrappers ${STAGING_BINDIR_NATIVE} |
| 68 | } |
| 69 | |
| 70 | do_install:append:class-nativesdk() { |
| 71 | create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk} |
| 72 | } |
| 73 | |
| 74 | create_wrappers() { |
| 75 | for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do |
| 76 | create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1 |
| 77 | done |
| 78 | } |
| 79 | |
| 80 | PACKAGECONFIG ??= "gnutls" |
| 81 | PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls" |
| 82 | PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3" |
| 83 | |
| 84 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 85 | |
| 86 | lcl_maybe_fortify:mipsarch = "" |
| 87 | |