Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "A curses client for the Music Player Daemon" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | HOMEPAGE = "https://www.musicpd.org/clients/ncmpc/" |
| 5 | |
| 6 | inherit meson |
| 7 | |
| 8 | DEPENDS += " \ |
| 9 | boost \ |
| 10 | ncurses \ |
| 11 | libmpdclient \ |
| 12 | " |
| 13 | |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 14 | PACKAGECONFIG ??= "colors locale mouse nls regex help_screen library_screen search_screen song_screen key_screen lyrics_screen outputs_screen" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | PACKAGECONFIG[colors] = "-Dcolors=true,-Dcolors=false" |
| 17 | PACKAGECONFIG[lirc] = "-Dlirc=enabled,-Dlirc=disabled,lirc" |
| 18 | PACKAGECONFIG[locale] = "-Dlocale=enabled,-Dlocale=disabled" |
| 19 | PACKAGECONFIG[mini] = "-Dmini=true,-Dmini=false" |
| 20 | PACKAGECONFIG[mouse] = "-Dmouse=enabled,-Dmouse=disabled" |
| 21 | PACKAGECONFIG[nls] = "-Dnls=enabled,-Dnls=disabled,gettext-native" |
| 22 | PACKAGECONFIG[regex] = "-Dregex=enabled,-Dregex=disabled,pcre" |
| 23 | |
| 24 | PACKAGECONFIG[help_screen] = "-Dhelp_screen=true,-Dhelp_screen=false" |
Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 25 | PACKAGECONFIG[library_screen] = "-Dlibrary_screen=true,-Dlibrary_screen=false" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | PACKAGECONFIG[search_screen] = "-Dsearch_screen=true,-Dsearch_screen=false" |
| 27 | PACKAGECONFIG[song_screen] = "-Dsong_screen=true,-Dsong_screen=false" |
| 28 | PACKAGECONFIG[key_screen] = "-Dkey_screen=true,-Dkey_screen=false" |
| 29 | PACKAGECONFIG[lyrics_screen] = "-Dlyrics_screen=true,-Dlyrics_screen=false" |
| 30 | PACKAGECONFIG[outputs_screen] = "-Doutputs_screen=true,-Doutputs_screen=false" |
| 31 | PACKAGECONFIG[chat_screen] = "-Dchat_screen=true,-Dchat_screen=false" |
| 32 | |
| 33 | SRC_URI = " \ |
| 34 | git://github.com/MusicPlayerDaemon/ncmpc \ |
| 35 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 36 | SRCREV = "2c71add42152072c5e0490de2870315dfb3b71e1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 37 | S = "${WORKDIR}/git" |