Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | require openssl10.inc |
| 2 | |
| 3 | # For target side versions of openssl enable support for OCF Linux driver |
| 4 | # if they are available. |
| 5 | |
| 6 | CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS" |
| 7 | CFLAG_append_class-native = " -fPIC" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f475368924827d06d4b416111c8bdb77" |
| 10 | |
| 11 | export DIRS = "crypto ssl apps engines" |
| 12 | export OE_LDFLAGS="${LDFLAGS}" |
| 13 | |
| 14 | SRC_URI += "file://find.pl;subdir=openssl-${PV}/util/ \ |
| 15 | file://run-ptest \ |
| 16 | file://openssl-c_rehash.sh \ |
| 17 | file://configure-targets.patch \ |
| 18 | file://shared-libs.patch \ |
| 19 | file://oe-ldflags.patch \ |
| 20 | file://engines-install-in-libdir-ssl.patch \ |
| 21 | file://debian1.0.2/block_diginotar.patch \ |
| 22 | file://debian1.0.2/block_digicert_malaysia.patch \ |
| 23 | file://debian/ca.patch \ |
| 24 | file://debian/c_rehash-compat.patch \ |
| 25 | file://debian/debian-targets.patch \ |
| 26 | file://debian/man-dir.patch \ |
| 27 | file://debian/man-section.patch \ |
| 28 | file://debian/no-rpath.patch \ |
| 29 | file://debian/no-symbolic.patch \ |
| 30 | file://debian/pic.patch \ |
| 31 | file://debian1.0.2/version-script.patch \ |
| 32 | file://debian1.0.2/soname.patch \ |
| 33 | file://openssl_fix_for_x32.patch \ |
| 34 | file://openssl-fix-des.pod-error.patch \ |
| 35 | file://Makefiles-ptest.patch \ |
| 36 | file://ptest-deps.patch \ |
| 37 | file://ptest_makefile_deps.patch \ |
| 38 | file://configure-musl-target.patch \ |
| 39 | file://parallel.patch \ |
| 40 | file://openssl-util-perlpath.pl-cwd.patch \ |
| 41 | file://Use-SHA256-not-MD5-as-default-digest.patch \ |
| 42 | file://0001-Fix-build-with-clang-using-external-assembler.patch \ |
| 43 | file://0001-openssl-force-soft-link-to-avoid-rare-race.patch \ |
| 44 | " |
| 45 | |
| 46 | SRC_URI_append_class-target = "\ |
| 47 | file://reproducible-cflags.patch \ |
| 48 | file://reproducible-mkbuildinf.patch \ |
| 49 | " |
| 50 | SRC_URI[md5sum] = "44279b8557c3247cbe324e2322ecd114" |
| 51 | SRC_URI[sha256sum] = "ec3f5c9714ba0fd45cb4e087301eb1336c317e0d20b575a125050470e8089e4d" |
| 52 | |
| 53 | PACKAGES =+ "${PN}-engines" |
| 54 | FILES_${PN}-engines = "${libdir}/ssl/engines/*.so ${libdir}/engines" |
| 55 | |
| 56 | # The crypto_use_bigint patch means that perl's bignum module needs to be |
| 57 | # installed, but some distributions (for example Fedora 23) don't ship it by |
| 58 | # default. As the resulting error is very misleading check for bignum before |
| 59 | # building. |
| 60 | do_configure_prepend() { |
| 61 | if ! perl -Mbigint -e true; then |
| 62 | bbfatal "The perl module 'bignum' was not found but this is required to build openssl. Please install this module (often packaged as perl-bignum) and re-run bitbake." |
| 63 | fi |
| 64 | } |