Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 1 | SUMMARY = "C++ framework for implementing distributed and networked applications" |
| 2 | DESCRIPTION = "C++ network programming framework that implements many core \ |
| 3 | patterns for concurrent communication software" |
| 4 | LICENSE = "ACE-TAO-CIAO" |
| 5 | HOMEPAGE = "http://www.dre.vanderbilt.edu/~schmidt/ACE.html" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=96ef88a5529594698e8ceabdd47df92c" |
| 7 | |
| 8 | DEPENDS += "openssl gperf-native" |
| 9 | |
| 10 | SRC_URI = "https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_8/ACE-${PV}.tar.bz2 \ |
| 11 | file://ace_config.patch \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "a6ba6a944612fe0696c90cbb5c3078ee" |
| 15 | SRC_URI[sha256sum] = "cda2a960dbb9970a907663627711b2e2b14b3484a2859ae936370bcad0b16923" |
| 16 | |
| 17 | COMPATIBLE_HOST_libc-musl = "null" |
| 18 | |
| 19 | S = "${WORKDIR}/ACE_wrappers" |
| 20 | B = "${WORKDIR}/ACE_wrappers/ace" |
| 21 | export ACE_ROOT="${WORKDIR}/ACE_wrappers" |
| 22 | |
| 23 | inherit pkgconfig |
| 24 | |
| 25 | CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations" |
| 26 | |
| 27 | do_install() { |
| 28 | export D="${D}" |
| 29 | oe_runmake install |
| 30 | |
| 31 | for i in $(find ${D} -name "*.pc") ; do |
| 32 | sed -i -e s:${D}::g \ |
| 33 | -e s:/${TARGET_SYS}::g \ |
| 34 | $i |
| 35 | done |
| 36 | |
| 37 | rm -r ${D}/usr/share |
| 38 | } |
| 39 | |
| 40 | UPSTREAM_CHECK_URI = "https://github.com/DOCGroup/ACE_TAO/releases" |