Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 1 | SUMMARY = "The Mercurial distributed SCM" |
| 2 | HOMEPAGE = "http://mercurial.selenic.com/" |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "python3 python3-native" |
| 8 | RDEPENDS_${PN} = "python3 python3-modules" |
| 9 | |
| 10 | inherit python3native |
| 11 | |
| 12 | SRC_URI = "https://www.mercurial-scm.org/release/${BP}.tar.gz" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 13 | SRC_URI[md5sum] = "0859029d0bb54bcf7c583c55680573cb" |
| 14 | SRC_URI[sha256sum] = "1df8d1978aefcbb65dc51e3666a452583f47aeaf3c5682e4c00a3b23cd805d6a" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/mercurial-${PV}" |
| 17 | |
| 18 | BBCLASSEXTEND = "native" |
| 19 | |
| 20 | export LDSHARED="${CCLD} -shared" |
| 21 | |
| 22 | EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \ |
| 23 | PREFIX=${prefix}" |
| 24 | |
| 25 | do_configure_append () { |
| 26 | sed -i -e 's:PYTHON?=python:PYTHON=python3:g' ${S}/Makefile |
| 27 | } |
| 28 | |
| 29 | do_install () { |
| 30 | oe_runmake -e install-bin DESTDIR=${D} PREFIX=${prefix} |
| 31 | sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/hg |
| 32 | } |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 33 | PACKAGES =+ "${PN}-python" |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 34 | |
| 35 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
| 36 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 37 | FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}" |
| 38 | |