Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Graph Visualization Tools" |
| 2 | HOMEPAGE = "http://www.graphviz.org" |
| 3 | LICENSE = "EPL-1.0" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=9109f5fc16cf963fb3cdd32781b3ce04" |
| 5 | |
| 6 | DEPENDS = " \ |
| 7 | intltool-native \ |
| 8 | bison-native \ |
| 9 | groff-native \ |
| 10 | libtool \ |
| 11 | gdk-pixbuf \ |
| 12 | librsvg \ |
| 13 | cairo \ |
| 14 | pango \ |
| 15 | expat \ |
| 16 | freetype \ |
| 17 | " |
| 18 | DEPENDS_append_class-target = " ${BPN}-native" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 19 | DEPENDS_append_class-nativesdk = " ${BPN}-native" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
| 21 | inherit autotools-brokensep pkgconfig gettext |
| 22 | |
| 23 | # The source tarball suggested at |
| 24 | # https://graphviz.gitlab.io/_pages/Download/Download_source.html has no |
| 25 | # version in its name. So once graphviz is updgraded, only first time users will |
| 26 | # get checksum errors. Fedora people seem to expect same so they use a versioned |
| 27 | # source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec |
| 28 | |
| 29 | SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 30 | file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | " |
| 32 | # Use native mkdefs |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 33 | SRC_URI_append_class-target = "\ |
| 34 | file://0001-Use-native-mkdefs.patch \ |
| 35 | file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \ |
| 36 | " |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 37 | SRC_URI_append_class-nativesdk = "\ |
| 38 | file://0001-Use-native-mkdefs.patch \ |
| 39 | file://graphviz-setup.sh \ |
| 40 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 41 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" |
| 42 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" |
| 43 | |
| 44 | S = "${WORKDIR}/${BPN}-stable_release_${PV}" |
| 45 | |
| 46 | EXTRA_OECONF_class-target = "\ |
| 47 | --with-expatincludedir=${STAGING_INCDIR} \ |
| 48 | --with-expatlibdir=${STAGING_LIBDIR} \ |
| 49 | --without-included-ltdl \ |
| 50 | --disable-java \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 51 | --disable-tcl \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 52 | --disable-r \ |
| 53 | --disable-sharp \ |
| 54 | " |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 55 | EXTRA_OECONF_class-nativesdk = "\ |
| 56 | --with-expatincludedir=${STAGING_INCDIR} \ |
| 57 | --with-expatlibdir=${STAGING_LIBDIR} \ |
| 58 | --without-included-ltdl \ |
| 59 | --disable-java \ |
| 60 | --disable-tcl \ |
| 61 | --disable-r \ |
| 62 | --disable-sharp \ |
| 63 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 64 | CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 65 | CFLAGS_append_class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 66 | do_configure_prepend() { |
| 67 | cd ${S} |
| 68 | # create version.m4 and ignore libtoolize errors |
| 69 | ./autogen.sh NOCONFIG || true |
| 70 | } |
| 71 | |
| 72 | do_install_append_class-native() { |
| 73 | # install mkdefs for target build |
| 74 | install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir} |
| 75 | } |
| 76 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 77 | do_install_append_class-nativesdk() { |
| 78 | # graphviz-setup.sh must be executed at SDK installation |
| 79 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d |
| 80 | install -m 0755 ${WORKDIR}/graphviz-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d |
| 81 | } |
| 82 | FILES_${PN}_class-nativesdk += "${SDKPATHNATIVE}" |
| 83 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 84 | PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo" |
| 85 | |
| 86 | FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/" |
| 87 | FILES_${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/" |
| 88 | FILES_${PN}-demo += "${datadir}/graphviz/demo/" |
| 89 | |
| 90 | RDEPENDS_${PN}-perl += "perl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 91 | RDEPENDS_${PN}-python += "python3" |
| 92 | RDEPENDS_${PN}-demo += "python3 perl" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 93 | |
| 94 | INSANE_SKIP_${PN}-perl = "dev-so" |
| 95 | INSANE_SKIP_${PN}-python = "dev-so" |
| 96 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 97 | FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}" |
| 98 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame^] | 99 | BBCLASSEXTEND = "native nativesdk" |