Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools" |
| 2 | HOMEPAGE = "https://github.com/gperftools/gperftools" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a" |
| 5 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 6 | SRCREV = "d8eb315fb18f6fb0d6efa923401f166343727bc6" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/gperftools/gperftools \ |
| 8 | file://0001-Support-Atomic-ops-on-clang.patch \ |
| 9 | file://0001-fix-build-with-musl-libc.patch \ |
| 10 | file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \ |
| 11 | file://disable_libunwind_aarch64.patch \ |
| 12 | file://sgidef.patch \ |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 13 | file://0001-profile-handler-Specify-libc-specific-thread_id.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | " |
| 15 | |
| 16 | inherit autotools |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | # On mips, we have the following error. |
| 21 | # do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008 |
| 22 | # Segmentation fault (core dumped) |
| 23 | COMPATIBLE_HOST_mipsarch = "null" |
| 24 | COMPATIBLE_HOST_riscv64 = "null" |
| 25 | COMPATIBLE_HOST_riscv32 = "null" |
| 26 | |
| 27 | # Disable thumb1 |
| 28 | # {standard input}: Assembler messages: |
| 29 | # {standard input}:434: Error: lo register required -- `ldr pc,[sp]' |
| 30 | # Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed |
| 31 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 32 | ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm" |
| 33 | |
| 34 | PACKAGECONFIG ?= "libunwind static" |
| 35 | PACKAGECONFIG_remove_arm_libc-musl = "libunwind" |
| 36 | PACKAGECONFIG_remove_riscv64 = "libunwind" |
| 37 | PACKAGECONFIG_remove_riscv32 = "libunwind" |
| 38 | |
| 39 | PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind" |
| 40 | PACKAGECONFIG[static] = "--enable-static,--disable-static," |
| 41 | |
| 42 | PACKAGE_BEFORE_PN += "libtcmalloc-minimal" |
| 43 | FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}" |
| 44 | |
| 45 | # pprof tool requires Getopt::long and POSIX perl5 modules. |
| 46 | # Also runs `objdump` on each cpuprofile data file |
| 47 | RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix" |
| 48 | |
| 49 | RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})" |
| 50 | |