blob: 2a386086f53cdc5ca1c7f7b2afb0d14bd1666b70 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
2HOMEPAGE = "https://github.com/gperftools/gperftools"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
5
Andrew Geissler72956ed2021-01-08 16:11:14 -06006SRCREV = "d8eb315fb18f6fb0d6efa923401f166343727bc6"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007SRC_URI = "git://github.com/gperftools/gperftools \
8 file://0001-Support-Atomic-ops-on-clang.patch \
9 file://0001-fix-build-with-musl-libc.patch \
10 file://0001-disbale-heap-checkers-and-debug-allocator-on-musl.patch \
11 file://disable_libunwind_aarch64.patch \
12 file://sgidef.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060013 file://0001-profile-handler-Specify-libc-specific-thread_id.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 "
15
16inherit autotools
17
18S = "${WORKDIR}/git"
19
20# On mips, we have the following error.
21# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
22# Segmentation fault (core dumped)
23COMPATIBLE_HOST_mipsarch = "null"
24COMPATIBLE_HOST_riscv64 = "null"
25COMPATIBLE_HOST_riscv32 = "null"
26
27# Disable thumb1
28# {standard input}: Assembler messages:
29# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
30# Makefile:4538: recipe for target 'src/base/libtcmalloc_la-linuxthreads.lo' failed
31ARM_INSTRUCTION_SET_armv5 = "arm"
32ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
33
34PACKAGECONFIG ?= "libunwind static"
35PACKAGECONFIG_remove_arm_libc-musl = "libunwind"
36PACKAGECONFIG_remove_riscv64 = "libunwind"
37PACKAGECONFIG_remove_riscv32 = "libunwind"
38
39PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
40PACKAGECONFIG[static] = "--enable-static,--disable-static,"
41
42PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
43FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"
44
45# pprof tool requires Getopt::long and POSIX perl5 modules.
46# Also runs `objdump` on each cpuprofile data file
47RDEPENDS_${PN} += "binutils perl-module-getopt-long perl-module-posix"
48
49RDEPENDS_${PN} += "libtcmalloc-minimal (= ${EXTENDPKGV})"
50