Patrick Williams | e73d216 | 2021-12-08 21:25:20 -0600 | [diff] [blame] | 1 | DESCRIPTION = "C++ Unified Executors library" |
| 2 | HOMEPAGE = "https://github.com/facebookexperimental/libunifex" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Apache-2.0-with-LLVM-exception" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5b86506074cb3cdc493b4f96b73b2909" |
| 6 | |
| 7 | SRC_URI = "git://github.com/facebookexperimental/libunifex.git;branch=main;protocol=https" |
| 8 | SRCREV = "9df21c58d34ce8a1cd3b15c3a7347495e29417a0" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit cmake pkgconfig |
| 13 | |
| 14 | PACKAGECONFIG ??= "liburing" |
| 15 | PACKAGECONFIG[liburing] = ",,liburing" |
| 16 | |
| 17 | EXTRA_OECMAKE += " \ |
| 18 | -DBUILD_SHARED_LIBS=ON \ |
| 19 | -DBUILD_TESTING=OFF \ |
| 20 | -DCMAKE_CXX_STANDARD=20 \ |
| 21 | -DUNIFEX_BUILD_EXAMPLES=OFF \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |