Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "File classification tool" |
| 2 | DESCRIPTION = "File attempts to classify files depending \ |
| 3 | on their contents and prints a description if a match is found." |
| 4 | HOMEPAGE = "http://www.darwinsys.com/file/" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | # two clause BSD |
| 8 | LICENSE = "BSD-2-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=0251eaec1188b20d9a72c502ecfdda1b" |
| 10 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 11 | DEPENDS = "file-replacement-native" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 12 | DEPENDS_class-native = "bzip2-replacement-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | SRC_URI = "git://github.com/file/file.git" |
| 15 | |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 16 | SRCREV = "87731415de945660b00f02207d8e9d986ef9b82e" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit autotools update-alternatives |
| 20 | |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 21 | PACKAGECONFIG ??= "zlib" |
| 22 | PACKAGECONFIG[bz2] = "--enable-bzlib, --disable-bzlib, bzip2" |
| 23 | PACKAGECONFIG[lzma] = "--enable-xzlib, --disable-xzlib, xz" |
| 24 | PACKAGECONFIG[zlib] = "--enable-zlib, --disable-zlib, zlib" |
| 25 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | EXTRA_OECONF += "--disable-libseccomp" |
| 27 | |
| 28 | ALTERNATIVE_${PN} = "file" |
| 29 | ALTERNATIVE_LINK_NAME[file] = "${bindir}/file" |
| 30 | |
| 31 | EXTRA_OEMAKE_append_class-target = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 32 | EXTRA_OEMAKE_append_class-nativesdk = " -e FILE_COMPILE=${STAGING_BINDIR_NATIVE}/file-native/file" |
| 33 | |
| 34 | FILES_${PN} += "${datadir}/misc/*.mgc" |
| 35 | |
| 36 | do_compile_append_class-native() { |
| 37 | oe_runmake check |
| 38 | } |
| 39 | |
| 40 | do_install_append_class-native() { |
| 41 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 42 | --magic-file ${datadir}/misc/magic.mgc |
| 43 | } |
| 44 | |
| 45 | do_install_append_class-nativesdk() { |
| 46 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 47 | --magic-file ${datadir}/misc/magic.mgc |
| 48 | } |
| 49 | |
| 50 | BBCLASSEXTEND = "native nativesdk" |
| 51 | PROVIDES_append_class-native = " file-replacement-native" |
| 52 | # Don't use NATIVE_PACKAGE_PATH_SUFFIX as that hides libmagic from anyone who |
| 53 | # depends on file-replacement-native. |
| 54 | bindir_append_class-native = "/file-native" |