Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 1 | require libva.inc |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 4 | SRC_URI[sha256sum] = "adbb1244d278908f89ccfcf254a442de6d71934565a492cb6f03caf2ed4d1ec3" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 6 | PACKAGECONFIG ??= " \ |
| 7 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \ |
| 8 | ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \ |
| 9 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 11 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes" |
| 12 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa" |
| 13 | |
| 14 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" |
| 17 | |
| 18 | RDEPENDS_${PN}-x11 =+ "${PN}" |
| 19 | RDEPENDS_${PN}-glx =+ "${PN}-x11" |
| 20 | |
| 21 | FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" |
| 22 | FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" |
| 23 | FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" |