Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "SDK for connecting to AWS IoT using Python." |
| 2 | HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python" |
| 3 | LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)" |
| 4 | LICENSE:${PN}-examples = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "\ |
| 6 | file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \ |
| 7 | file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \ |
| 8 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 9 | SRCREV = "0ea1a2d013529839fc1e7448d19dadff25d581b4" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | SRC_URI = "git://github.com/aws/aws-iot-device-sdk-python;branch=master;protocol=https \ |
| 11 | file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit setuptools3 |
| 17 | |
| 18 | PYPI_PACKAGE = "AWSIoTPythonSDK" |
| 19 | |
| 20 | do_install:append() { |
| 21 | install -d -m0755 ${D}${datadir}/${BPN}/examples |
| 22 | cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples |
| 23 | # this requires the full blown AWS Python SDK |
| 24 | rm -r ${D}${datadir}/${BPN}/examples/basicPubSub |
| 25 | } |
| 26 | |
| 27 | PACKAGES =+ "${PN}-examples" |
| 28 | |
| 29 | RDEPENDS:${PN} += " \ |
| 30 | ${PYTHON_PN}-crypt \ |
| 31 | ${PYTHON_PN}-datetime \ |
| 32 | ${PYTHON_PN}-io \ |
| 33 | ${PYTHON_PN}-json \ |
| 34 | ${PYTHON_PN}-logging \ |
| 35 | ${PYTHON_PN}-math \ |
| 36 | ${PYTHON_PN}-netclient \ |
| 37 | ${PYTHON_PN}-numbers \ |
| 38 | ${PYTHON_PN}-threading \ |
| 39 | " |
| 40 | RDEPENDS:${PN}-examples += "${PN}" |
| 41 | |
| 42 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |