Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>" |
| 2 | DESCRIPTION = "\ |
| 3 | The PyMongo distribution contains tools for interacting with MongoDB \ |
| 4 | database from Python. The bson package is an implementation of the BSON \ |
| 5 | format for Python. The pymongo package is a native Python driver for \ |
| 6 | MongoDB. The gridfs package is a gridfs implementation on top of pymongo." |
| 7 | HOMEPAGE = "http://github.com/mongodb/mongo-python-driver" |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 10 | |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "dbba77bc0b706c7ee496fc75a6c6ed406d85f6091d5fec488a8944c3828e6462" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | |
| 13 | inherit pypi setuptools3 |
| 14 | |
| 15 | PACKAGES =+ "${PYTHON_PN}-bson" |
| 16 | |
| 17 | FILES:${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*" |
| 18 | |
| 19 | RDEPENDS:${PYTHON_PN}-bson += " \ |
| 20 | ${PYTHON_PN}-datetime \ |
| 21 | ${PYTHON_PN}-json \ |
| 22 | ${PYTHON_PN}-netclient \ |
| 23 | ${PYTHON_PN}-numbers \ |
| 24 | ${PYTHON_PN}-threading \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN} += " \ |
| 28 | ${PYTHON_PN}-bson \ |
| 29 | ${PYTHON_PN}-pprint \ |
| 30 | " |