Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | # Copyright (C) 2022 Wind River Systems |
| 2 | |
| 3 | SUMMARY = "Use your fixtures in @pytest.mark.parametrize." |
| 4 | HOMEPAGE = "https://github.com/tvorog/pytest-lazy-fixture" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=aae6f2b7c9b3ced83e0b5bb42346d4dd" |
| 7 | |
| 8 | SRC_URI[sha256sum] = "0e7d0c7f74ba33e6e80905e9bfd81f9d15ef9a790de97993e34213deb5ad10ac" |
| 9 | |
| 10 | SRC_URI += "file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | |
| 14 | inherit ptest pypi setuptools3 |
| 15 | |
| 16 | do_install_ptest() { |
| 17 | install -d ${D}${PTEST_PATH}/tests |
| 18 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 19 | } |
| 20 | |
| 21 | |
| 22 | RDEPENDS:${PN} += "python3-core python3-pytest" |
| 23 | RDEPENDS:${PN}-ptest = " python3-unixadmin" |