Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Trace and analyze execution of a program written in C/C++" |
| 2 | HOMEPAGE = "https://github.com/namhyung/uftrace" |
| 3 | BUGTRACKER = "https://github.com/namhyung/uftrace/issues" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | DEPENDS = "elfutils" |
| 9 | DEPENDS_append_libc-musl = " argp-standalone" |
| 10 | |
| 11 | inherit autotools |
| 12 | |
Andrew Geissler | e231d58 | 2020-05-05 08:53:09 -0500 | [diff] [blame] | 13 | SRCREV = "d648bbffedef529220896283fb59e35531c13804" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | SRC_URI = "git://github.com/namhyung/${BPN} \ |
| 15 | " |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 18 | PR .= "+git${SRCPV}" |
| 19 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | LDFLAGS_append_libc-musl = " -largp" |
| 21 | |
| 22 | def set_target_arch(d): |
| 23 | import re |
| 24 | arch = d.getVar('TARGET_ARCH') |
| 25 | if re.match(r'i.86', arch, re.I): |
| 26 | return 'i386' |
| 27 | elif re.match('armeb', arch, re.I): |
| 28 | return 'arm' |
| 29 | else: |
| 30 | return arch |
| 31 | |
| 32 | EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \ |
| 33 | with_elfutils=/use/libelf/from/sysroot" |
| 34 | |
| 35 | do_configure() { |
| 36 | ${S}/configure ${EXTRA_UFTRACE_OECONF} |
| 37 | } |
| 38 | |
| 39 | FILES_SOLIBSDEV = "" |
| 40 | FILES_${PN} += "${libdir}/*.so" |
| 41 | |
| 42 | COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)" |
| 43 | |
| 44 | # uftrace supports armv6 and above |
| 45 | COMPATIBLE_HOST_armv4 = 'null' |
| 46 | COMPATIBLE_HOST_armv5 = 'null' |