blob: 732fe3b451f2c3414caaeacddc2555421cd68e3e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Trace and analyze execution of a program written in C/C++"
2HOMEPAGE = "https://github.com/namhyung/uftrace"
3BUGTRACKER = "https://github.com/namhyung/uftrace/issues"
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8DEPENDS = "elfutils"
9DEPENDS_append_libc-musl = " argp-standalone"
10
11inherit autotools
12
Andrew Geisslere231d582020-05-05 08:53:09 -050013SRCREV = "d648bbffedef529220896283fb59e35531c13804"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014SRC_URI = "git://github.com/namhyung/${BPN} \
15 "
16S = "${WORKDIR}/git"
17
Andrew Geissler7f40b712020-05-15 14:09:53 -050018PR .= "+git${SRCPV}"
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020LDFLAGS_append_libc-musl = " -largp"
21
22def set_target_arch(d):
23 import re
24 arch = d.getVar('TARGET_ARCH')
25 if re.match(r'i.86', arch, re.I):
26 return 'i386'
27 elif re.match('armeb', arch, re.I):
28 return 'arm'
29 else:
30 return arch
31
32EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \
33 with_elfutils=/use/libelf/from/sysroot"
34
35do_configure() {
36 ${S}/configure ${EXTRA_UFTRACE_OECONF}
37}
38
39FILES_SOLIBSDEV = ""
40FILES_${PN} += "${libdir}/*.so"
41
42COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)"
43
44# uftrace supports armv6 and above
45COMPATIBLE_HOST_armv4 = 'null'
46COMPATIBLE_HOST_armv5 = 'null'