Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
| 3 | HOMEPAGE = "http://github.com/openbmc/sdbusplus" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit autotools pkgconfig |
Patrick Williams | 8fc9629 | 2016-11-22 07:01:14 -0600 | [diff] [blame^] | 9 | inherit obmc-phosphor-python-autotools |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 10 | |
| 11 | DEPENDS += "autoconf-archive-native" |
| 12 | RDEPENDS_${PN} += " \ |
| 13 | python-inflection \ |
| 14 | python-mako \ |
| 15 | python-pyyaml \ |
| 16 | " |
| 17 | |
| 18 | SRC_URI += "git://github.com/openbmc/sdbusplus" |
Patrick Williams | 6695dd3 | 2016-11-18 15:30:03 -0600 | [diff] [blame] | 19 | SRCREV = "aa71a3ed5dc2d128223ff3dc5f0c04474be40803" |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 20 | |
| 21 | PACKAGECONFIG ??= "libsdbusplus" |
| 22 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 27 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
| 28 | |
Brad Bishop | e327803 | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 29 | BBCLASSEXTEND += "native nativesdk" |