Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images" |
| 2 | DESCRIPTION = "The gd graphics library allows your code to quickly draw images \ |
| 3 | complete with lines, arcs, text, multiple colors, cut and paste from other \ |
| 4 | images, and flood fills, and to write out the result as a PNG or JPEG file. \ |
| 5 | This is particularly useful in Web applications, where PNG and JPEG are two \ |
| 6 | of the formats accepted for inline images by most browsers. Note that gd is not \ |
| 7 | a paint program." |
| 8 | HOMEPAGE = "http://libgd.bitbucket.org/" |
| 9 | |
| 10 | SECTION = "libs" |
| 11 | LICENSE = "GD" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=07384b3aa2e0d39afca0d6c40286f545" |
| 13 | |
| 14 | DEPENDS = "freetype libpng jpeg zlib tiff" |
| 15 | |
| 16 | SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | file://0001-annotate.c-gdft.c-Replace-strncpy-with-memccpy-to-fi.patch \ |
| 18 | file://CVE-2018-1000222.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | SRCREV = "8255231b68889597d04d451a72438ab92a405aba" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools binconfig gettext pkgconfig |
| 26 | |
| 27 | EXTRA_OECONF += " --disable-rpath \ |
| 28 | --with-jpeg=${STAGING_LIBDIR}/.. \ |
| 29 | --with-freetype=yes \ |
| 30 | --without-fontconfig \ |
| 31 | --without-webp \ |
| 32 | --without-xpm \ |
| 33 | --without-x \ |
| 34 | " |
| 35 | |
| 36 | EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' |
| 37 | |
| 38 | do_install_append() { |
| 39 | # cleanup buildpaths from gdlib.pc |
| 40 | sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc |
| 41 | } |
| 42 | |
| 43 | PACKAGES += "${PN}-tools" |
| 44 | |
| 45 | FILES_${PN} = "${libdir}/lib*${SOLIBS}" |
| 46 | FILES_${PN}-tools = "${bindir}/*" |
| 47 | |
| 48 | PROVIDES += "${PN}-tools" |
| 49 | RPROVIDES_${PN}-tools = "${PN}-tools" |
| 50 | RDEPENDS_${PN}-tools = "perl perl-module-strict" |