Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python." |
| 2 | HOMEPAGE = "https://www.h5py.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "8752d2814a92aba4e2b2a5922d2782d0029102d99caaf3c201a566bc0b40db29" |
| 8 | |
| 9 | SRC_URI:append = " \ |
| 10 | file://0001-setup_build.py-avoid-absolute-path.patch \ |
| 11 | " |
| 12 | |
| 13 | inherit pkgconfig pypi setuptools3 |
| 14 | |
| 15 | BBCLASSEXTEND = "native" |
| 16 | |
| 17 | DEPENDS = "python3-pkgconfig-native \ |
| 18 | python3-cython-native \ |
| 19 | python3-numpy-native \ |
| 20 | python3-six-native \ |
| 21 | hdf5-native \ |
| 22 | python3 \ |
| 23 | hdf5 \ |
| 24 | " |
| 25 | |
| 26 | RDEPENDS:${PN} = "python3-numpy \ |
| 27 | python3-six \ |
| 28 | python3-json \ |
| 29 | " |
| 30 | |
| 31 | export HDF5_VERSION="1.8.21" |