Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "File classification tool" |
| 2 | DESCRIPTION = "File attempts to classify files depending \ |
| 3 | on their contents and prints a description if a match is found." |
| 4 | HOMEPAGE = "http://www.darwinsys.com/file/" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | # two clause BSD |
| 8 | LICENSE = "BSD" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03188" |
| 10 | |
| 11 | DEPENDS = "zlib file-native" |
| 12 | DEPENDS_class-native = "zlib-native" |
| 13 | |
| 14 | SRC_URI = "git://github.com/file/file.git \ |
| 15 | file://debian-742262.patch \ |
| 16 | file://0001-Add-P-prompt-into-Usage-info.patch \ |
| 17 | " |
| 18 | |
| 19 | SRCREV = "3c0874be4d3232d672b20f513451a39cfd7c585a" |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit autotools |
| 23 | |
| 24 | FILES_${PN} += "${datadir}/misc/*.mgc" |
| 25 | |
| 26 | do_install_append_class-native() { |
| 27 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 28 | --magic-file ${datadir}/misc/magic.mgc |
| 29 | } |
| 30 | |
| 31 | do_install_append_class-nativesdk() { |
| 32 | create_cmdline_wrapper ${D}/${bindir}/file \ |
| 33 | --magic-file ${datadir}/misc/magic.mgc |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native nativesdk" |