Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Troff software" |
| 2 | DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \ |
| 3 | formatting commands and produces formatted output." |
| 4 | SECTION = "console/utils" |
| 5 | HOMEPAGE = "http://www.gnu.org/software/groff/" |
| 6 | LICENSE = "GPLv2" |
| 7 | PR = "r1" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=e43fc16fccd8519fba405f0a0ff6e8a3" |
| 10 | |
| 11 | SRC_URI = "${GNU_MIRROR}/${BPN}/old/${BP}.tar.gz \ |
| 12 | file://groff-1.18.1.4-remove-mom.patch;striplevel=1 \ |
| 13 | file://man-local.patch \ |
| 14 | file://mdoc-local.patch \ |
| 15 | file://groff-1.18.1.4-fix-bindir.patch \ |
| 16 | " |
| 17 | |
| 18 | inherit autotools texinfo |
| 19 | |
| 20 | EXTRA_OECONF="--without-x --prefix=${D} --exec-prefix=${D} --bindir=${D}${bindir} --datadir=${D}${datadir} --mandir=${D}${datadir}/man --infodir=${D}${datadir}info --with-appresdir=${D}${datadir}" |
| 21 | |
| 22 | SRC_URI[md5sum] = "ceecb81533936d251ed015f40e5f7287" |
| 23 | SRC_URI[sha256sum] = "ff3c7c3b6cae5e8cc5062a144de5eff0022e8e970e1774529cc2d5dde46ce50d" |
| 24 | PARALLEL_MAKE = "" |
| 25 | |
| 26 | do_configure (){ |
| 27 | oe_runconf |
| 28 | } |
| 29 | |
| 30 | do_install_append() { |
| 31 | # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location |
| 32 | # for target as /usr/bin/perl, so fix it to /usr/bin/perl. |
| 33 | for i in afmtodit mmroff; do |
| 34 | if [ -f ${D}${bindir}/$i ]; then |
| 35 | sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i |
| 36 | fi |
| 37 | done |
| 38 | |
| 39 | mkdir -p ${D}${sysconfdir}/groff |
| 40 | cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${sysconfdir}/groff/ |
| 41 | cp -rf ${D}${datadir}/groff/site-tmac/* ${D}${datadir}/groff/${PV}/tmac/ |
| 42 | } |
| 43 | |
| 44 | pkg_postinst_${PN}() { |
| 45 | ln -s tbl $D${bindir}/gtbl |
| 46 | echo "export GROFF_FONT_PATH=/usr/share/groff/${PV}/font" >> $D${sysconfdir}/profile |
| 47 | echo "export GROFF_TMAC_PATH=/usr/share/groff/${PV}/tmac" >> $D${sysconfdir}/profile |
| 48 | } |
| 49 | |