Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A user-space tool to show and modify the state of GPIOs on the S3c24xx platform" |
| 2 | SECTION = "console/utils" |
| 3 | AUTHOR = "Werner Almesberger <werner@openmoko.org>" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://gpio.c;endline=12;md5=cfb91c686857b2e60852b4925d90a3e1" |
| 6 | SRCREV = "4949" |
| 7 | PV = "1.0+svnr${SRCPV}" |
| 8 | PR = "r2" |
| 9 | |
| 10 | SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gpio;protocol=http" |
| 11 | S = "${WORKDIR}/gpio" |
| 12 | |
| 13 | CLEANBROKEN = "1" |
| 14 | |
| 15 | do_compile() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | ${CC} ${CFLAGS} ${LDFLAGS} -o ${PN} gpio.c |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | } |
| 18 | |
| 19 | do_install() { |
| 20 | install -d ${D}${sbindir} |
| 21 | install -m 0755 ${PN} ${D}${sbindir} |
| 22 | } |