Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "The Perl Database Interface" |
| 2 | DESCRIPTION = "DBI is a database access Application Programming Interface \ |
| 3 | (API) for the Perl Language. The DBI API Specification defines a set \ |
| 4 | of functions, variables and conventions that provide a consistent \ |
| 5 | database interface independent of the actual database being used. \ |
| 6 | " |
| 7 | HOMEPAGE = "http://search.cpan.org/dist/DBI/" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5" |
| 11 | |
| 12 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz" |
| 13 | SRC_URI[md5sum] = "f2ba18b5cea1c8cb322a62be0a847f3d" |
| 14 | SRC_URI[sha256sum] = "3f2025023a56286cebd15cb495e36ccd9b456c3cc229bf2ce1f69e9ebfc27f5d" |
| 15 | |
| 16 | S = "${WORKDIR}/DBI-${PV}" |
| 17 | |
| 18 | inherit cpan ptest-perl |
| 19 | |
| 20 | do_install_prepend() { |
| 21 | # test requires "-T" (taint) command line option |
| 22 | rm -rf ${B}/t/pod-coverage.t |
| 23 | rm -rf ${B}/t/13taint.t |
| 24 | # source of test failure not obvious |
| 25 | rm -rf ${B}/t/85gofer.t |
| 26 | # unclear why there are several duplicates of tests in tarball |
| 27 | rm -rf ${B}/t/z*.t |
| 28 | } |
| 29 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 30 | RDEPENDS_${PN}_class-target = " \ |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame^] | 31 | perl \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 32 | perl-module-carp \ |
| 33 | perl-module-exporter \ |
| 34 | perl-module-exporter-heavy \ |
| 35 | perl-module-dynaloader \ |
| 36 | perl-module-io-dir \ |
| 37 | perl-module-scalar-util \ |
| 38 | perl-module-universal \ |
| 39 | " |
| 40 | |
| 41 | RDEPENDS_${PN}-ptest = " \ |
| 42 | ${PN} \ |
| 43 | perl-module-b \ |
| 44 | perl-module-benchmark \ |
| 45 | perl-module-cwd \ |
| 46 | perl-module-data-dumper \ |
| 47 | perl-module-encode \ |
| 48 | perl-module-encode-byte \ |
| 49 | perl-module-encode-encoding \ |
| 50 | perl-module-file-copy \ |
| 51 | perl-module-file-path \ |
| 52 | perl-module-lib \ |
| 53 | perl-module-perlio \ |
| 54 | perl-module-perlio-scalar \ |
| 55 | perl-module-perlio-via \ |
| 56 | perl-module-sdbm-file \ |
| 57 | perl-module-storable \ |
| 58 | perl-module-test-more \ |
| 59 | perl-module-utf8 \ |
| 60 | " |
| 61 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 62 | BBCLASSEXTEND = "native" |