Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "netkit-telnet includes the telnet daemon and client." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://www.hcs.harvard.edu/~dholland/computers/netkit.html" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 3 | SECTION = "net" |
| 4 | DEPENDS = "ncurses" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 5 | LICENSE = "BSD-4-Clause" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://telnet/telnet.cc;beginline=2;endline=3;md5=780868e7b566313e70cb701560ca95ef" |
| 7 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | SRC_URI = "http://ftp.linux.org.uk/pub/linux/Networking/netkit/${BP}.tar.gz \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | file://To-aviod-buffer-overflow-in-telnet.patch \ |
| 10 | file://Warning-fix-in-the-step-of-install.patch \ |
| 11 | file://telnet-xinetd \ |
| 12 | file://cross-compile.patch \ |
| 13 | file://0001-telnet-telnetd-Fix-print-format-strings.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | file://0001-telnet-telnetd-Fix-deadlock-on-cleanup.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | file://CVE-2020-10188.patch \ |
Andrew Geissler | 748a483 | 2020-07-24 16:24:21 -0500 | [diff] [blame] | 16 | file://0001-telnetd-utility.c-Fix-buffer-overflow-in-netoprintf.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 17 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/n/netkit-telnet/" |
| 20 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.orig\.tar" |
| 21 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 22 | EXTRA_OEMAKE = "INSTALLROOT=${D} SBINDIR=${sbindir} DAEMONMODE=755 \ |
| 23 | MANMODE=644 MANDIR=${mandir}" |
| 24 | |
| 25 | do_configure () { |
| 26 | ./configure --prefix=${prefix} |
| 27 | sed -e 's#^CFLAGS=\(.*\)$#CFLAGS= -D_GNU_SOURCE \1#' \ |
| 28 | -e 's#^CXXFLAGS=\(.*\)$#CXXFLAGS= -D_GNU_SOURCE \1#' \ |
| 29 | -e 's#^LDFLAGS=.*$#LDFLAGS= ${LDFLAGS}#' \ |
| 30 | -i MCONFIG |
| 31 | } |
| 32 | |
| 33 | do_compile () { |
| 34 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet |
| 35 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' LIBS=-lutil SUB=telnetd |
| 36 | oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnetlogin |
| 37 | } |
| 38 | |
| 39 | do_install () { |
| 40 | install -d ${D}${bindir} |
| 41 | install -m 0755 telnet/telnet ${D}${bindir}/telnet.${PN} |
| 42 | install -d ${D}${sbindir} |
| 43 | install -d ${D}${mandir}/man1 |
| 44 | install -d ${D}${mandir}/man5 |
| 45 | install -d ${D}${mandir}/man8 |
| 46 | oe_runmake SUB=telnetd install |
| 47 | rm -rf ${D}${mandir}/man1 |
| 48 | install -D -m 4750 ${B}/telnetlogin/telnetlogin ${D}/${libdir}/telnetlogin |
| 49 | # fix up hardcoded paths |
| 50 | sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/telnet-xinetd |
| 51 | install -d ${D}/etc/xinetd.d/ |
| 52 | install -p -m644 ${WORKDIR}/telnet-xinetd ${D}/etc/xinetd.d/telnet |
| 53 | } |
| 54 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 55 | inherit update-alternatives |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 56 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | ALTERNATIVE_PRIORITY = "100" |
| 58 | ALTERNATIVE_${PN} = "telnet" |
| 59 | ALTERNATIVE_LINK_NAME[telnet] = "${bindir}/telnet" |
| 60 | ALTERNATIVE_TARGET[telnet] = "${bindir}/telnet.${PN}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 61 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 62 | ALTERNATIVE_${PN}-doc = "telnetd.8" |
| 63 | ALTERNATIVE_LINK_NAME[telnetd.8] = "${mandir}/man8/telnetd.8" |
| 64 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 65 | SRC_URI[md5sum] = "d6beabaaf53fe6e382c42ce3faa05a36" |
| 66 | SRC_URI[sha256sum] = "9c80d5c7838361a328fb6b60016d503def9ce53ad3c589f3b08ff71a2bb88e00" |
| 67 | FILES_${PN} += "${sbindir}/in.* ${libdir}/* ${sysconfdir}/xinetd.d/*" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 68 | |
| 69 | # http://errors.yoctoproject.org/Errors/Details/186954/ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 70 | COMPATIBLE_HOST_libc-musl = 'null' |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 71 | RCONFLICTS_${PN} = "inetutils-telnetd" |