Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "display dialog boxes from shell scripts" |
| 2 | DESCRIPTION = "Dialog lets you to present a variety of questions \ |
| 3 | or display messages using dialog boxes from a shell \ |
| 4 | script (or any scripting language)." |
| 5 | HOMEPAGE = "http://invisible-island.net/dialog/" |
| 6 | SECTION = "console/utils" |
| 7 | DEPENDS = "ncurses" |
| 8 | LICENSE = "LGPL-2.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 10 | |
| 11 | SRC_URI = "ftp://ftp.invisible-island.net/${BPN}/${BP}.tgz \ |
| 12 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 13 | SRC_URI[md5sum] = "f7a3c240af305b5282af590541e8f4b7" |
| 14 | SRC_URI[sha256sum] = "466163e8b97c2b7709d00389199add3156bd813f60ccb0335d0a30f2d4a17f99" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | # hardcoded here for use in dialog-static recipe |
| 17 | S = "${WORKDIR}/dialog-${PV}" |
| 18 | |
| 19 | inherit autotools-brokensep pkgconfig |
| 20 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 21 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 22 | |
| 23 | PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11" |
| 24 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | EXTRA_OECONF = "--with-ncurses \ |
| 26 | --disable-rpath-hack" |
| 27 | |
| 28 | do_configure() { |
| 29 | gnu-configize --force |
| 30 | sed -i 's,${cf_ncuconfig_root}6-config,${cf_ncuconfig_root}-config,g' -i configure |
| 31 | sed -i 's,cf_have_ncuconfig=unknown,cf_have_ncuconfig=yes,g' -i configure |
| 32 | oe_runconf |
| 33 | } |