Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Multi-purpose linux bootloader" |
| 2 | HOMEPAGE = "http://www.syslinux.org/" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 3 | DESCRIPTION = "The Syslinux Project covers lightweight bootloaders for MS-DOS FAT filesystems (SYSLINUX), network booting (PXELINUX), bootable "El Torito" CD-ROMs (ISOLINUX), and Linux ext2/ext3/ext4 or btrfs filesystems (EXTLINUX). The project also includes MEMDISK, a tool to boot legacy operating systems (such as DOS) from nontraditional media; it is usually used in conjunction with PXELINUX and ISOLINUX." |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 6 | file://README;beginline=35;endline=41;md5=558f2c71cb1fb9ba511ccd4858e48e8a" |
| 7 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | DEPENDS = "nasm-native util-linux e2fsprogs" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | |
| 10 | SRC_URI = "https://www.zytor.com/pub/syslinux/Testing/6.04/syslinux-${PV}.tar.xz \ |
| 11 | file://syslinux-remove-clean-script.patch \ |
| 12 | file://0001-linux-syslinux-support-ext2-3-4-device.patch \ |
| 13 | file://0002-linux-syslinux-implement-open_ext2_fs.patch \ |
| 14 | file://0003-linux-syslinux-implement-install_to_ext2.patch \ |
| 15 | file://0004-linux-syslinux-add-ext_file_read-and-ext_file_write.patch \ |
| 16 | file://0005-linux-syslinux-implement-handle_adv_on_ext.patch \ |
| 17 | file://0006-linux-syslinux-implement-write_to_ext-and-add-syslin.patch \ |
| 18 | file://0007-linux-syslinux-implement-ext_construct_sectmap_fs.patch \ |
| 19 | file://0008-libinstaller-syslinuxext-implement-syslinux_patch_bo.patch \ |
| 20 | file://0009-linux-syslinux-implement-install_bootblock.patch \ |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 21 | file://0010-Workaround-multiple-definition-of-symbol-errors.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | file://0001-install-don-t-install-obsolete-file-com32.ld.patch \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 23 | file://determinism.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | " |
| 25 | |
| 26 | SRC_URI[md5sum] = "2b31c78f087f99179feb357da312d7ec" |
| 27 | SRC_URI[sha256sum] = "4441a5d593f85bb6e8d578cf6653fb4ec30f9e8f4a2315a3d8f2d0a8b3fadf94" |
| 28 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 29 | # remove at next version upgrade or when output changes |
| 30 | PR = "r1" |
| 31 | HASHEQUIV_HASH_VERSION .= ".1" |
| 32 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 33 | RECIPE_NO_UPDATE_REASON = "6.04-pre3 is broken" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 34 | UPSTREAM_CHECK_URI = "https://www.zytor.com/pub/syslinux/" |
| 35 | UPSTREAM_CHECK_REGEX = "syslinux-(?P<pver>.+)\.tar" |
| 36 | UPSTREAM_VERSION_UNKNOWN = "1" |
| 37 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 38 | # We can build the native parts anywhere, but the target has to be x86 |
| 39 | COMPATIBLE_HOST_class-target = '(x86_64|i.86).*-(linux|freebsd.*)' |
| 40 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 41 | # Don't let the sanity checker trip on the 32 bit real mode BIOS binaries |
| 42 | INSANE_SKIP_${PN}-misc = "arch" |
| 43 | INSANE_SKIP_${PN}-chain = "arch" |
| 44 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 45 | # When building the installer, CC is used to link. When building the bootloader, |
| 46 | # LD is used. However, these variables assume that GCC is used and break the |
| 47 | # build, so unset them. |
| 48 | TARGET_LDFLAGS = "" |
| 49 | SECURITY_LDFLAGS = "" |
| 50 | LDFLAGS_SECTION_REMOVAL = "" |
| 51 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 52 | CFLAGS_append = " -DNO_INLINE_FUNCS" |
| 53 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 54 | EXTRA_OEMAKE = " \ |
| 55 | BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \ |
| 56 | DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 57 | CC="${CC} ${CFLAGS} ${LDFLAGS}" \ |
| 58 | LD="${LD} ${LDFLAGS}" \ |
| 59 | OBJDUMP="${OBJDUMP}" \ |
| 60 | OBJCOPY="${OBJCOPY}" \ |
| 61 | AR="${AR}" \ |
| 62 | STRIP="${STRIP}" \ |
| 63 | NM="${NM}" \ |
| 64 | RANLIB="${RANLIB}" \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 65 | " |
| 66 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 67 | # |
| 68 | # Tasks for native/nativesdk which just build the installer. |
| 69 | # |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 70 | do_configure() { |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 71 | oe_runmake firmware="bios" clean |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 72 | } |
| 73 | |
| 74 | do_compile() { |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 75 | oe_runmake firmware="bios" installer |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 76 | } |
| 77 | |
| 78 | do_install() { |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 79 | install -d ${D}${bindir} |
| 80 | install \ |
| 81 | ${B}/bios/mtools/syslinux \ |
| 82 | ${B}/bios/extlinux/extlinux \ |
| 83 | ${B}/bios/utils/isohybrid \ |
| 84 | ${D}${bindir} |
| 85 | } |
| 86 | |
| 87 | # |
| 88 | # Tasks for target which ship the precompiled bootloader and installer |
| 89 | # |
| 90 | do_configure_class-target() { |
| 91 | # No need to do anything as we're mostly shipping the precompiled binaries |
| 92 | : |
| 93 | } |
| 94 | |
| 95 | do_compile_class-target() { |
| 96 | # No need to do anything as we're mostly shipping the precompiled binaries |
| 97 | : |
| 98 | } |
| 99 | |
| 100 | do_install_class-target() { |
| 101 | oe_runmake firmware="bios" install INSTALLROOT="${D}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 102 | |
| 103 | install -d ${D}${datadir}/syslinux/ |
| 104 | install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/ |
| 105 | install -m 644 ${S}/bios/core/ldlinux.bss ${D}${datadir}/syslinux/ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 106 | } |
| 107 | |
| 108 | PACKAGES += "${PN}-nomtools ${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc" |
| 109 | |
| 110 | RDEPENDS_${PN} += "mtools" |
| 111 | RDEPENDS_${PN}-nomtools += "libext2fs" |
| 112 | RDEPENDS_${PN}-misc += "perl" |
| 113 | |
| 114 | FILES_${PN} = "${bindir}/syslinux" |
| 115 | FILES_${PN}-nomtools = "${bindir}/syslinux-nomtools" |
| 116 | FILES_${PN}-extlinux = "${sbindir}/extlinux" |
| 117 | FILES_${PN}-mbr = "${datadir}/${BPN}/mbr.bin" |
| 118 | FILES_${PN}-chain = "${datadir}/${BPN}/chain.c32" |
| 119 | FILES_${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin" |
| 120 | FILES_${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0" |
| 121 | FILES_${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld" |
| 122 | FILES_${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a" |
| 123 | FILES_${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*" |
| 124 | |
| 125 | BBCLASSEXTEND = "native nativesdk" |