Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace RCU (read-copy-update) library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 2 | DESCRIPTION = "A userspace RCU (read-copy-update) library. This data \ |
| 3 | synchronization library provides read-side access which scales linearly \ |
| 4 | with the number of cores. " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 5 | HOMEPAGE = "http://lttng.org/urcu" |
| 6 | BUGTRACKER = "http://lttng.org/project/issues" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1+ & MIT-style" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \ |
| 10 | file://include/urcu/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \ |
| 11 | file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b" |
| 12 | |
| 13 | SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2" |
| 14 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame^] | 15 | SRC_URI[md5sum] = "d94347df78e3f1aa744745eb85787df5" |
| 16 | SRC_URI[sha256sum] = "4eefc11e4f6c212fc7d84d871e1cc139da0669a46ff3fda557a6fdd4d74ca67b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | S = "${WORKDIR}/userspace-rcu-${PV}" |
| 19 | inherit autotools multilib_header |
| 20 | |
| 21 | CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT" |
| 22 | |
| 23 | do_install_append() { |
| 24 | oe_multilib_header urcu/config.h |
| 25 | } |