Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Linux tool to dump x86 CPUID information about the CPU(s)" |
| 2 | DESCRIPTION = "cpuid dumps detailed information about the CPU(s) gathered \ |
| 3 | from the CPUID instruction, and also determines the exact model of CPU(s). \ |
| 4 | It supports Intel, AMD, and VIA CPUs, as well as older Transmeta, Cyrix, \ |
| 5 | UMC, NexGen, Rise, and SiS CPUs" |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 8 | |
| 9 | SRC_URI = "http://www.etallen.com/${BPN}/${BP}.src.tar.gz \ |
| 10 | " |
| 11 | SRC_URI[md5sum] = "b3b4e44ef49575043a91def0207dcc76" |
| 12 | SRC_URI[sha256sum] = "967823be36f23cbc972eb0aa882d069c1d155a5978990ac3bcf425e6a2e7ff9a" |
| 13 | |
| 14 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 15 | |
| 16 | # The install rule from the Makefile has hardcoded paths, so we duplicate |
| 17 | # the actions to accommodate different paths. |
| 18 | do_install () { |
| 19 | install -D -m 0755 ${B}/cpuid ${D}/${bindir}/cpuid |
| 20 | install -D -m 0444 ${B}/cpuid.man.gz ${D}/${mandir} |
| 21 | } |