Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "network auditing tool" |
| 2 | DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf" |
| 3 | SECTION = "security" |
| 4 | LICENSE = "GPL-2.0" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=1489288f46af415fadc4e8b6345ab9f4" |
| 7 | |
| 8 | SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \ |
| 9 | file://nmap-redefine-the-python-library-dir.patch \ |
| 10 | file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \ |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 11 | file://0001-include-time.h-for-time-structure-definition.patch \ |
| 12 | file://0002-Fix-building-with-libc.patch \ |
| 13 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | SRC_URI[md5sum] = "84eb6fbe788e0d4918c2b1e39421bf79" |
| 16 | SRC_URI[sha256sum] = "847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18" |
| 17 | |
| 18 | inherit autotools-brokensep pkgconfig pythonnative |
| 19 | |
| 20 | PACKAGECONFIG ?= "ncat nping ndiff pcap" |
| 21 | |
| 22 | PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap" |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 23 | PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpcre" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl" |
| 25 | PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2" |
| 26 | PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib" |
| 27 | |
| 28 | #disable/enable packages |
| 29 | PACKAGECONFIG[nping] = ",--without-nping," |
| 30 | PACKAGECONFIG[ncat] = ",--without-ncat," |
| 31 | PACKAGECONFIG[ndiff] = ",--without-ndiff,python" |
| 32 | PACKAGECONFIG[update] = ",--without-nmap-update," |
| 33 | |
| 34 | EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included" |
| 35 | |
| 36 | # zenmap needs python-pygtk which has been removed |
| 37 | # it also only works with python2 |
| 38 | # disable for now until py3 is supported |
| 39 | EXTRA_OECONF += "--without-zenmap" |
| 40 | |
| 41 | export PYTHON_SITEPACKAGES_DIR |
| 42 | |
| 43 | do_configure() { |
| 44 | autoconf |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 45 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 46 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | oe_runconf |
| 48 | } |
| 49 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 50 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR} ${datadir}/ncat" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 51 | |
| 52 | RDEPENDS_${PN} = "python" |