Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema" |
| 2 | HOMEPAGE = "https://github.com/devicetree-org/dt-schema" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811" |
| 5 | |
| 6 | inherit pypi setuptools3 |
| 7 | |
| 8 | PYPI_PACKAGE = "dtschema" |
| 9 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "2238753fa16bee7b26841cced75d745af777b896190f40aff5802992335201bb" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "python3-setuptools-scm-native" |
| 13 | RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |