Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Password and keyring managing daemon" |
| 2 | HOMEPAGE = "http://www.gnome.org/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 9 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = " \ |
| 13 | glib-2.0-native \ |
| 14 | gtk+3 \ |
| 15 | gcr \ |
| 16 | libgcrypt \ |
| 17 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \ |
| 18 | " |
| 19 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 20 | inherit gnomebase gsettings features_check gettext |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 22 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 23 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 24 | SRC_URI[archive.sha256sum] = "a3d24db08ee2fdf240fbbf0971a98c8ee295aa0e1a774537f4ea938038a3b931" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 25 | SRC_URI += " \ |
| 26 | file://0001-Set-paths-to-ssh-agent-and-ssh-add-by-configure-opti.patch \ |
| 27 | file://musl.patch \ |
| 28 | " |
| 29 | |
| 30 | PACKAGECONFIG ??= "ssh-agent" |
| 31 | PACKAGECONFIG[ssh-agent] = "--enable-ssh-agent --with-ssh-agent-path=${bindir}/ssh-agent --with-ssh-add-path=${bindir}/ssh-add,--disable-ssh-agent,,openssh-misc" |
| 32 | |
| 33 | EXTRA_OECONF = " \ |
| 34 | --disable-doc \ |
| 35 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)} \ |
| 36 | " |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} += " \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 39 | ${datadir}/dbus-1/services \ |
| 40 | ${datadir}/p11-kit \ |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 41 | ${datadir}/xdg-desktop-portal \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 42 | ${base_libdir}/security/*${SOLIBSDEV} \ |
| 43 | ${libdir}/pkcs11/gnome-keyring-pkcs11.so \ |
| 44 | " |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 45 | # fix | gnome-keyring-daemon: insufficient process capabilities, unsecure memory might get used |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | pkg_postinst:${PN} () { |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 47 | setcap cap_ipc_lock+ep $D/${bindir}/gnome-keyring-daemon |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 48 | } |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 49 | PACKAGE_WRITE_DEPS += "libcap-native" |