Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 1 | SUMMARY = "A library to abstract stream I/O like serial port, TCP, telnet, etc" |
| 2 | HOMEPAGE = "https://github.com/cminyard/gensio" |
| 3 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a0fd36908af843bcee10cb6dfc47fa67 \ |
| 5 | file://COPYING;md5=bae3019b4c6dc4138c217864bd04331f \ |
| 6 | " |
| 7 | |
| 8 | SRCREV = "b6cd354afe6d5f63bc859c94fd3a455a3cdf0449" |
| 9 | |
| 10 | SRC_URI = "git://github.com/cminyard/gensio;protocol=https;branch=master \ |
| 11 | file://0001-tools-gensiot-Fix-build-with-musl.patch \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit autotools |
| 17 | |
| 18 | PACKAGECONFIG ??= "openssl tcp-wrappers" |
| 19 | |
| 20 | PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}${prefix},--without-openssl, openssl" |
| 21 | PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers, tcp-wrappers" |
| 22 | PACKAGECONFIG[swig] = "--with-swig,--without-swig, swig" |
| 23 | |
| 24 | EXTRA_OECONF = "--without-python" |
| 25 | |
| 26 | RDEPENDS:${PN} += "bash" |