Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame^] | 1 | DESCRIPTION = "lib-curses provides an interface between Perl programs and \ |
| 2 | the curses library." |
| 3 | |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09" |
| 8 | |
| 9 | DEPENDS += "perl ncurses " |
| 10 | |
| 11 | SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "fb9efea8c7b5ed5f8ea5dee49d35252accfc05ee6e75cb9a37ab7c847cd261d7" |
| 14 | |
| 15 | S = "${WORKDIR}/Curses-${PV}" |
| 16 | |
| 17 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}" |
| 18 | |
| 19 | inherit cpan |
| 20 | |
| 21 | do_compile() { |
| 22 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 23 | cpan_do_compile |
| 24 | } |
| 25 | |