Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A Python generic test automation framework" |
| 2 | DESCRIPTION = "Generic open source test atomation framework for acceptance\ |
| 3 | testing and acceptance test-driven development (ATDD). It has easy-to-use\ |
| 4 | tabular test data syntax and it utilizes the keyword-driven testing approach.\ |
| 5 | Its testing capabilities can be extended by test libraries implemented either\ |
| 6 | with Python or Java, and users can create new higher-level keywords from\ |
| 7 | existing ones using the same syntax that is used for creating test cases." |
| 8 | HOMEPAGE = "http://robotframework.org" |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 14 | PYPI_PACKAGE_EXT = "zip" |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 15 | |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame^] | 16 | SRC_URI[sha256sum] = "663f84c177b2fa9b3b782939e31637a057a33f3a4b29067812f1259b7f4bad35" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | ${PYTHON_PN}-shell \ |
| 20 | ${PYTHON_PN}-pprint \ |
| 21 | ${PYTHON_PN}-xml \ |
| 22 | ${PYTHON_PN}-difflib \ |
| 23 | ${PYTHON_PN}-threading \ |
| 24 | ${PYTHON_PN}-html \ |
| 25 | ${PYTHON_PN}-docutils \ |
| 26 | ${PYTHON_PN}-ctypes \ |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | ${PYTHON_PN}-logging \ |
| 28 | ${PYTHON_PN}-numbers \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | " |