Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Web-based MySQL administration interface" |
| 2 | HOMEPAGE = "http://www.phpmyadmin.net" |
| 3 | # Main code is GPLv2, vendor/tecnickcom/tcpdf is under LGPLv3, js/jquery is under MIT |
| 4 | LICENSE = "GPLv2 & LGPLv3 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://vendor/tecnickcom/tcpdf/LICENSE.TXT;md5=dd6470bbcd3436ca317f82d34abaf688 \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 7 | file://js/vendor/jquery/MIT-LICENSE.txt;md5=75308107741f7dcdc39127209c7e3fc8 \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 8 | " |
| 9 | |
| 10 | SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \ |
| 11 | file://apache.conf \ |
| 12 | " |
| 13 | |
Patrick Williams | 93c203f | 2021-10-06 16:15:23 -0500 | [diff] [blame^] | 14 | SRC_URI[md5sum] = "e73377b11b7d38fa3f3014f2799c5252" |
| 15 | SRC_URI[sha256sum] = "1964d7190223c11e89fa1b7970c618e3a3bae2e859f5f60383f64c3848ef6921" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://www.phpmyadmin.net/downloads/" |
| 18 | UPSTREAM_CHECK_REGEX = "phpMyAdmin-(?P<pver>\d+(\.\d+)+)-all-languages.tar.xz" |
| 19 | |
| 20 | S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages" |
| 21 | |
| 22 | inherit allarch |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${datadir}/${BPN} |
| 26 | cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN} |
| 27 | chown -R root:root ${D}${datadir}/${BPN} |
| 28 | # Don't install patches to target |
| 29 | rm -rf ${D}${datadir}/${BPN}/patches |
| 30 | |
| 31 | install -d ${D}${sysconfdir}/apache2/conf.d |
| 32 | install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf |
| 33 | |
| 34 | # Remove a few scripts that explicitly require bash (!) |
| 35 | rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} = "${datadir}/${BPN} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | ${sysconfdir}/apache2/conf.d" |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | RDEPENDS:${PN} += "bash php-cli" |