Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "ltrace intercepts and records dynamic library calls" |
| 2 | |
| 3 | DESCRIPTION = "ltrace intercepts and records dynamic library calls \ |
| 4 | which are called by an executed process and the signals received by that process. \ |
| 5 | It can also intercept and print the system calls executed by the program.\ |
| 6 | " |
| 7 | HOMEPAGE = "http://ltrace.org/" |
| 8 | |
| 9 | LICENSE = "GPLv2" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 11 | |
| 12 | PE = "1" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | PV = "7.91+git${SRCPV}" |
| 14 | SRCREV = "c22d359433b333937ee3d803450dc41998115685" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | |
| 16 | DEPENDS = "elfutils" |
| 17 | RDEPENDS_${PN} = "elfutils" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 18 | SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=master \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 19 | file://configure-allow-to-disable-selinux-support.patch \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 20 | file://0001-replace-readdir_r-with-readdir.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | file://0001-Use-correct-enum-type.patch \ |
| 22 | file://0002-Fix-const-qualifier-error.patch \ |
| 23 | file://0001-ARM-code-has-unreachable-code-after-switch-statement.patch \ |
| 24 | file://0001-Fix-tautological-compare-warning.patch \ |
| 25 | file://0001-Add-support-for-mips64-n32-n64.patch \ |
| 26 | file://0001-configure-Recognise-linux-musl-as-a-host-OS.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 27 | file://0001-mips-plt.c-Delete-include-error.h.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | S = "${WORKDIR}/git" |
| 30 | |
| 31 | inherit autotools |
| 32 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 33 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 34 | PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind" |
| 35 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" |
| 36 | |
| 37 | do_configure_prepend () { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 38 | ( cd ${S}; ./autogen.sh ) |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 39 | } |