Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A library for bits of crypto UI and parsing etc" |
| 2 | DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \ |
| 3 | accessing key stores. It also provides the viewer for crypto files on the \ |
| 4 | GNOME desktop." |
| 5 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr" |
| 6 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 10 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame^] | 11 | DEPENDS = "p11-kit glib-2.0 libgcrypt gnupg-native \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 12 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}" |
| 13 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 14 | CACHED_CONFIGUREVARS += "ac_cv_path_GPG='gpg2'" |
| 15 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 16 | GNOMEBASEBUILDCLASS = "meson" |
| 17 | GTKDOC_MESON_OPTION = "gtk_doc" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | inherit gnomebase gtk-icon-cache gtk-doc features_check upstream-version-is-even vala gobject-introspection gettext mime mime-xdg |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 19 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 20 | SRC_URI[archive.sha256sum] = "17fcaf9c4a93a65fb1c72b82643bb102c13344084687d5886ea66313868d9ec9" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame^] | 22 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)}" |
| 23 | PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk+3" |
| 24 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 25 | FILES_${PN} += " \ |
| 26 | ${datadir}/dbus-1 \ |
| 27 | ${datadir}/gcr-3 \ |
| 28 | " |
| 29 | |
| 30 | # http://errors.yoctoproject.org/Errors/Details/20229/ |
| 31 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 32 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 33 | ARM_INSTRUCTION_SET_armv6 = "arm" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 34 | |
| 35 | EXTRA_OEMESON += "--cross-file ${WORKDIR}/meson-${PN}.cross" |
| 36 | do_write_config_append() { |
| 37 | cat >${WORKDIR}/meson-${PN}.cross <<EOF |
| 38 | [binaries] |
| 39 | gpg2 = '${bindir}/gpg2' |
| 40 | EOF |
| 41 | } |