Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | # Copyright (C) 2017 Armin Kuster <akuster808@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Lynis is a free and open source security and auditing tool." |
| 5 | HOMEDIR = "https://cisofy.com/" |
| 6 | LICENSE = "GPL-3.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3edd6782854304fd11da4975ab9799c1" |
| 8 | |
| 9 | SRC_URI = "https://cisofy.com/files/${BPN}-${PV}.tar.gz" |
| 10 | |
| 11 | SRC_URI[md5sum] = "5b9da89c616344bbc73cbc5688a4a0bd" |
| 12 | SRC_URI[sha256sum] = "7a09c6fc71c65d572ca702df7b4394d71f9037484062ef71b76f59a2c498b029" |
| 13 | |
| 14 | S = "${WORKDIR}/${BPN}" |
| 15 | |
| 16 | inherit autotools-brokensep |
| 17 | |
| 18 | do_compile[noexec] = "1" |
| 19 | do_configure[noexec] = "1" |
| 20 | |
| 21 | do_install () { |
| 22 | install -d ${D}/${bindir} |
| 23 | install -d ${D}/${sysconfdir}/lynis |
| 24 | install -m 555 ${S}/lynis ${D}/${bindir} |
| 25 | |
| 26 | install -d ${D}/${datadir}/lynis/db |
| 27 | install -d ${D}/${datadir}/lynis/plugins |
| 28 | install -d ${D}/${datadir}/lynis/include |
| 29 | install -d ${D}/${datadir}/lynis/extras |
| 30 | |
| 31 | cp -r ${S}/db/* ${D}/${datadir}/lynis/db/. |
| 32 | cp -r ${S}/plugins/* ${D}/${datadir}/lynis/plugins/. |
| 33 | cp -r ${S}/include/* ${D}/${datadir}/lynis/include/. |
| 34 | cp -r ${S}/extras/* ${D}/${datadir}/lynis/extras/. |
| 35 | cp ${S}/*.prf ${D}/${sysconfdir}/lynis |
| 36 | } |
| 37 | |
| 38 | FILES_${PN} += "${sysconfdir}/developer.prf ${sysconfdir}/default.prf" |
| 39 | FILES_${PN}-doc += "lynis.8 FAQ README CHANGELOG.md CONTRIBUTIONS.md CONTRIBUTORS.md" |
| 40 | |
| 41 | RDEPENDS_${PN} += "procps" |