Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | DESCRIPTION = "The Apache HTTP Server is a powerful, efficient, and \ |
| 2 | extensible web server." |
| 3 | SUMMARY = "Apache HTTP Server" |
| 4 | HOMEPAGE = "http://httpd.apache.org/" |
| 5 | DEPENDS = "expat-native pcre-native apr-native apr-util-native" |
| 6 | SECTION = "net" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | |
| 9 | inherit autotools pkgconfig native |
| 10 | |
| 11 | SRC_URI = "${APACHE_MIRROR}/httpd/httpd-${PV}.tar.bz2 \ |
| 12 | file://0001-configure-use-pkg-config-for-PCRE-detection.patch \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/httpd-${PV}" |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a62b0c7623826ff99766ff13fb9007f8" |
| 18 | SRC_URI[md5sum] = "0c599404ef6b69eee95bcd9fcd094407" |
| 19 | SRC_URI[sha256sum] = "777753a5a25568a2a27428b2214980564bc1c38c1abf9ccc7630b639991f7f00" |
| 20 | |
| 21 | EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ |
| 22 | --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \ |
| 23 | --prefix=${prefix} --datadir=${datadir}/apache2 \ |
| 24 | " |
| 25 | |
| 26 | do_install () { |
| 27 | install -d ${D}${bindir} ${D}${libdir} |
| 28 | cp server/gen_test_char ${D}${bindir} |
| 29 | install -m 755 support/apxs ${D}${bindir}/ |
| 30 | install -m 755 httpd ${D}${bindir}/ |
| 31 | install -d ${D}${datadir}/apache2/build |
| 32 | cp ${S}/build/*.mk ${D}${datadir}/apache2/build |
| 33 | cp build/*.mk ${D}${datadir}/apache2/build |
| 34 | cp ${S}/build/instdso.sh ${D}${datadir}/apache2/build |
| 35 | |
| 36 | install -d ${D}${includedir}/apache2 |
| 37 | cp ${S}/include/* ${D}${includedir}/apache2 |
| 38 | cp include/* ${D}${includedir}/apache2 |
| 39 | cp ${S}/os/unix/os.h ${D}${includedir}/apache2 |
| 40 | cp ${S}/os/unix/unixd.h ${D}${includedir}/apache2 |
| 41 | |
| 42 | cp support/envvars-std ${D}${bindir}/envvars |
| 43 | chmod 755 ${D}${bindir}/envvars |
| 44 | } |
| 45 | |