Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "GNU Aspell spell-checker" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | |
| 3 | DESCRIPTION = "Spell checker designed to eventually replace Ispell. \ |
| 4 | It can either be used as a library or as an independent spell checker. \ |
| 5 | Its main feature is that it does a superior job of suggesting possible \ |
| 6 | replacements for a misspelled word than just about any other spell \ |
| 7 | checker out there for the English language." |
| 8 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | SECTION = "console/utils" |
| 10 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 11 | HOMEPAGE = "http://aspell.net/" |
| 12 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | LICENSE = "LGPLv2 | LGPLv2.1" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 15 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 16 | SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 17 | SRC_URI[md5sum] = "012fa9209203ae4e5a61c2a668fd10e3" |
| 18 | SRC_URI[sha256sum] = "f9b77e515334a751b2e60daab5db23499e26c9209f5e7b7443b05235ad0226f2" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 19 | |
| 20 | PACKAGECONFIG ??= "" |
| 21 | PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses" |
| 22 | |
| 23 | PACKAGES += "libaspell libpspell aspell-utils" |
| 24 | |
| 25 | RDEPENDS_${PN}-utils += "perl" |
| 26 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*" |
| 28 | FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*" |
| 29 | FILES_${PN} = "${bindir}/aspell" |
| 30 | FILES_libpspell = "${libdir}/libpspell.so.*" |
| 31 | FILES_${PN}-dev += "${bindir}/pspell-config" |
| 32 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 34 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 35 | ARM_INSTRUCTION_SET_armv6 = "arm" |
| 36 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 37 | inherit autotools-brokensep gettext texinfo binconfig-disabled |
| 38 | |
| 39 | BINCONFIG = "${bindir}/pspell-config" |